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This product note is a hands-on 
tutorial that walks you through 
implementing often-used data error
correction, reduction, and formatting
techniques used in rotating machin-
ery diagnostics. The examples will
assist prospective users in evaluating
an Agilent Dynamic Signal Analyzer
(DSA) for use in rotating machinery
analysis, and veteran users will 
acquire new tools and techniques to
more accurately and rapidly deter-
mine a machine’s condition. The pur-
pose of the note is to show you how
to use Computed Order Analysis and
Waveform Math in Agilent DSAs to
assist you in extracting the maximum
amount of information available from
machine vibration measurements. Us-
ing one instrument with a single user
interface to capture and reduce the
data minimizes the number of incom-
patible test instruments needed to
measure and document a machine’s
behavior. The diagnostician can more

quickly isolate the probable cause
from all the possible causes of exces-
sive machine vibration. The note
walks you through the data reduction
process using setup states and runup
vibration data on the 3½” floppy disk
(p/n 5966-0518E).

The topics covered are:

Two additional sections cover prox-
imity probes and tachometer/keypha-
sor interfacing issues with the 35670A
DSA. Each section includes step-by-
step examples that will assist you in
implementing these functions on an
35670A DSA. The examples at the end
of each section start by recalling time
capture data, measurement state, and
the waveform math functions to pro-
duce results quickly. Then the exam-
ple walks you through changes to the
data reduction setup state variables
and display setups to obtain the
results. The changes will illustrate
how easy it is to modify the measure-
ment state and the effects on the
results. The complete manual setup
sequence is provided when appropri-
ate. This approach is intended to 
provide the background and an un-
derstanding of the technique, as well
as to help you find your way around
in the DSA. It is hoped that with a
better understanding of the function-
ality in your 35670A, you will be
inspired to go beyond what is 
presented here. 

Section 1  
Introduction

• Phase Scaling Convention 
and Conversion

• Slow Roll Removal From 
X-Y Order Records

• Slow Roll Removal From Orbits

• Orbit Rotation To Horizontal 
and Vertical 

• Slow Roll Compensation of 
Bodé Plots

• Shaft Centerline Position 
Versus RPM and/or Time

• Magnitude, Phase, and RPM 
Numerical Display
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In rotating machinery diagnosis, 
a machine – at best – allows only 
limited access for vibration measure-
ments. From this limited set of vibra-
tion data, the diagnostician must
rapidly and accurately extract the
information needed to assess a
machine’s condition. The more infor-
mation that can be extracted from the
vibration data, the better the judg-
ment call on the machine’s condition
will be. These judgment calls have
very expensive consequences, and
therefore speed and accuracy are crit-
ical to success. This note is intended
to show the users of Agilent DSAs
how to get the maximum amount of
information from the available vibra-
tion data set. The diagnostician
extracts and enhances the informa-
tion from the data by removing
errors, reducing data using different
techniques, and displaying the results
in different formats. Each format or
display enhances the information in
different ways. The diagnostician
looks for consistency in the fault indi-
cators and looks for other possible
anomalies or contradictions in the
machine’s vibration response data.

Traditionally, to be able to look 
at data in multiple ways, the diagnos-
tician needed to bring a variety of
widely different kinds of instrumenta-
tion to measure and reduce the data.
In the past, digital vector filters were
used to examine filtered and unfil-
tered orbits, to make Bodé and polar

plots, and read out magnitude, phase
and RPM of an order of rotation. A
spectrum analyzer was required to
provide spectral maps, waterfall spec-
trums, etc. An analog or digital tape
recorder was used to capture data for
further analysis. A portable computer
and some custom software to control
the data acquisition and data reduc-
tion were often required. Many times
the data reduction tasks were done
manually or not at all. This all trans-
lated into time-consuming and
tedious data reduction tasks requiring
many different instruments, all with
incompatible and mostly proprietary
data formats.

Order tracking analysis evolved using
analog/digital tracking filters referred
to as digital vector filters (DVFs). The
DVFs provided tracking filters with

user-selectable bandwidths that were
set to track a multiple of the shaft
speed. The user needed to optimize
the tradeoffs between the RPM ramp
rate and selectivity (tracking filter
bandwidth.) The DVF provided user-
selectable fixed-bandwidth tracking
filters. For a bandpass filter with a
bandwidth of 60 CPM (1.0 Hz), the
output response would reach 63% of
the peak in 1 second and 95% of the
peak in 3 seconds for a sine wave
burst input at the filter’s center fre-
quency (Fig. 2.1). The filtered meas-
urement values will lag the true
values for signals that are changing
amplitude faster than the settling
time. DVFs depended on phase
locked loop (PLL) technology to
track an order of rotation, which
made optimizing order selectivity 
and speed ramp rates more 

Section 2 
Background

Fig. 2.1 
The step response of 
an analog tracking 
filter with a 60 CPM 
bandwidth filter follows 
the exponential curve 
as shown. If the 
machine’s speed ramp 
rate is too fast for the 
filter settling time, the 
indicated vibration levels 
will be less than their 
true values.

120 CPM Step
Sinewave

60 CPM
Bandwidth 63% 89% 94%

time
1 sec 2 sec 3 sec
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complicated (Fig. 2.2). The DVFs 
interfaced directly to proximity
probes and keyphasor signals as well
as to other transducers. The DVF dis-
played shaft RPM, bearing clearances
(gap), and phase angle relative to the
once-per-revolution phase reference.
Synchronously filtered data could 
be viewed by connecting an oscillo-
scope. Bodé and polar plots were 
produced by connecting to an analog
or digital X-Y plotter. The DVFs were
real workhorses for vibration analysis
and are still much admired for their
orbit displays, large numerical 
readout, and ease of use (Fig. 2.3). 

The data acquisition and data 
reduction speed advantages of the
first- and second-generation Fast
Fourier Transform-based dynamic sig-
nal analyzers made them very attrac-
tive prospects for rotating machinery
analysis. Some of these early high-end
DSAs were equipped with external
sampling inputs that could interface
with a machine’s tach signal and
could be triggered from the once-per-
revolution keyphasor. An FFT analyz-
er could measure hundreds of orders
at one time, which looked very attrac-
tive compared to the one order per
channel on a DVF. The realities of
doing order tracking required an 
external tracking ratio synthesizer

(TRS) to lock the DSA sampling to
the tach signal from a rotor. The TRS
multiplied the shaft tach so the DSA
was sampling at uniform angles of
rotation. The FFT works best with
128, 256, or 512 samples per revolu-
tion (2n) and an integer number of
revolutions in the data record. It was 
often worth the difficulties to 

install a custom tach (toothed wheel)
to provide the needed 2n pulses per
revolution just to eliminate the TRS.
The TRS could not maintain perfect
lock to the shaft rotation as the speed
ramped up. The tracking of RPM over
multiple speed ranges was also diffi-
cult. A digital tracking low pass filter
also was needed to minimize aliasing

Fig. 2.2 
The deviation of 
an “ideal” phase 
locked loop’s 
estimate of a 
shaft’s angular 
position from the 
shaft’s actual 
position for 
a constant 
RPM ramp.

Fig. 2.3 
The unfiltered 
orbits in the upper 
traces produced 
the filtered orbits 
in the lower traces. 
The DVF tracking 
filters used PLL 
to tune to the 
order being 
filtered. 
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Fig. 2.4 
Older DSAs could 
be configured to 
do order domain 
analysis by adding 
a tracking ratio 
synthesizer and 
tracking low pass 
filters. But 
tracking accuracy, 
dynamic range, 
and speed ramp 
rate suffered 
due to phase 
locked loop 
implementation 
in these external 
boxes. 
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errors (Fig. 2.4). Since these external 
devices used phase locked loops to
implement both the tracking filter
and shaft keyphasor multiplication,
the DSA’s dynamic range, RPM track-
ing speed, and trackable speed ranges
all suffered. The biggest problem was
the variable phase tracking error that
was inherent with phase locked loops
(Fig. 2.2).

In 1987, Agilent Technologies intro-
duced the breakthrough technology
of Computed Order Analysis, which
uses the same digital signal process-
ing hardware required for FFT spec-
trum analysis to implement order
analysis*. An elegant digital resam-
pling algorithm now allows Agilent
DSAs to do much of the work that
once required a DVF, a portable com-
puter, and an oscilloscope (Fig. 2.5). 

Computed order analysis overcomes
the inherent problems associated
with phase locked loop based
approaches. One can record a vibra-
tion data set from a machine startup
transient using the DSA time capture
feature and reduce the data in many
different ways. One can view orbits,
extract Bodé and polar plots on five
orders at a time, produce RPM spec-
tral maps, order maps, do slow roll
error removal, etc. One can also view
time or order data records, easily
convert displacement to velocity or
make other conversions. All of these

Fig. 2.5 
The block diagram 
of a DSA with digital 
resampling for Order 
Domain Analysis looks 
the same as a standard 
DSA block diagram 
with addition of a 
tach input. The 
all-digital approach 
eliminated PLL tracking 
errors and minimized 
speed tracking errors. 
Data accuracy 
and data dynamic 
range were also
greatly enhanced. 
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results can often be produced and
plotted in less time than it would 
take to set up and rewind an analog
or digital tape recorder. Accurate cali-
brated results can now be viewed
quickly, on site, with a minimum of
instrumentation.

The DSA’s order tracking and order
spectrum filters provide proportional
bandwidth (BW) tracking filters. The
filter’s bandwidth changes with the
machine’s speed. For example, at 
600 CPM (10 Hz) and with a delta
order set to 0.1, the DSA’s tracking fil-
ter bandwidth would be 0.1 X 10 Hz
or 1 Hz. Because we are using an FFT
to produce these filters, the settling
time equivalent for the 1 Hz BW filter
is 1 second. At 6000 CPM (100 Hz),
the tracking filter BW is 0.1 X 100 Hz
or 10 Hz wide. The settling time
equivalent would be 0.1 second. The
DSA, by default, automatically pro-
vides the optimum tracking speed
and tracking filter BW. Computed
order analysis equips the DSA with
measurement capability that can 
handle higher RPM speed ramp rates
with better phase and amplitude
accuracy than is possible with 
phase locked loops. 

The vector magnitude and angle are
the primary values used to identify
the relative size and location of an
imbalance (heavy spot) on a rotor.
Magnitude and phase changes versus
speed (Bodé and polar plots) are the
primary tools used to measure rotor
critical speeds and to do diagnostic
work. The phase convention used in
machinery vibration, plane geometry,
and the electrical power industry is a
0° to 360° phase lag scale. However,
two other phase conventions are 
also commonly used. They are the 
0° to ±180° and the 0° to -360° scales.
These three scales are shown in 
Fig. 3.1. The ±180° convention is 
commonly used in communication
and electronics technology. The 0° to 
-360° scaling is commonly used in
servo mechanism Bodé plots.  The 

0° to 360° phase lag implies a 0° to 
-360° scale without the minus sign.
The default phase convention used in
Agilent DSAs is the ±180° scaling.  

Fortunately, all the phase conventions
start at the same zero point and are
exactly equivalent. Converting from
the DSA’s default ±180° phase scale to
the 0° to 360° phase lag convention
used in rotor dynamics is straightfor-
ward. It is important to understand
these phase conventions in order to
effectively communicate. A great deal
of machine vibration history was 
collected with DVFs and plotted with
the 0° to 360° phase lag scaling. Stan-
dardizing on a phase convention that
is consistent with that used for past
measurements made by DVFs will
minimize communication and 

Section 3  
Phase Scaling Convention 
and Conversion

Fig. 3.1 
Three phase scaling 
conventions are in 
common use: 0° to -360°, 
0° to ±180°, and 0° to 360°. 
The DSA’s default scaling 
of ±180° is easily converted 
to the 0° to 360° phase lag 
scaling used by Digital 
Vector Filters.

180° -180°+180
-180°

90°

+90°

-90°

-270°

-90°

270°

0° 0°
+360°

0°
-360°

Servo Mechanism 0° to -360°

DSA Phase ±180°

Phase Lag 0° to 360°
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interpretation errors. You should
choose and use phase and magnitude
scales that are historically consistent.
In this manner one can avoid possibly
disastrous consequences.

The once-per-revolution phase refer-
ence relates the rotating coordinate
system of a machine to the stationary
coordinate system of the vibration
sensor. To illustrate, a simple rotor
system with a heavy spot rotating
well below the first critical is
assumed (Fig. 3.2.) The phase refer-
ence trigger point allows the high
spot’s angular location to be deter-
mined relative to the proximity probe.
The phase lag angle is determined by
looking back in time from the interval
ratio between the positive peak of the
vibration signal at tpk to the time for
one revolution, T. The time goes for-
ward (to the left) and the phase lag is
backward (to the right) in time. The
phase lag is based on the ratio:

φ = (tpk/T) 360°

Depicted in Figures 3.2 through 3.5
are ideal vibration signals for four
imbalance locations. For a vibration
peak (minimum gap) at t0 in Fig. 3.2,
the imbalance is located directly
under the proximity probe when the
keyway leading edge crosses the
phase sensor. For Fig. 3.3, the peak
vibration occurs at t1/T revolutions or
90° counter rotation from the proxim-
ity probe location. In other words, the
shaft must rotate 90° more after the
keyway crosses the phase sensor
before the high spot is under the
proximity probe. Another way of 
saying the same thing is to say that
the heavy spot is located 90° counter 
rotation from the proximity probe.
Depicted in Fig. 3.4 and 3.5 are 
imbalances located at 180° (t2/T) 
and 270° (t3/T). 

Fig. 3.2 
The shaft heavy spot 
causes a vibration peak 
(minimum gap) at t0. The 
high spot is directly under 
the proximity probe when 
the keyway passes across 
the phase sensor.

Fig. 3.3 
The heavy spot causes a 
vibration peak (minimum gap) 
at time t1. The shaft must rotate 
90° clockwise after the keyway 
passes the phase sensor before 
the high/heavy spot is under the 
proximity probe. The heavy spot 
can be located at 90° counter 
rotation from the proximity probe.
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The single most common point 
of confusion in vibration work cen-
ters on the relative location of the
heavy spot. From this presentation, it
should be clear that phase measure-
ments are relative to the proximity
probe, not to the keyway phase sen-
sor. The keyway only provides the
trigger point. The phase angle is the 
number of degrees of rotation the 
rotor must travel before the heavy
spot, or minimum gap, is under the
proximity probe.

Converting to Phase Lag 
using the Agilent 35670A

Phase lag scaling in the 35670A is
now a simple matter of going to the
Display Format, function Phase Lag
On/Off, and toggling it On. The soft-
ware release A.00.24 and higher adds
the phase lag scaling. The details on
using phase lag in the 35670A are 
covered in the example section. 
The background on the conversion
process from one phase convention
to another is easily accomplished
with the Y-axis scaling function or 
by selecting phase lag scaling. To 
convert from the default ±180° scale
of the DSA to 0° to -360° scaling, the
Y-axis scaling function is used to set
0° top and -360° bottom references.
What happens when the phase lag
scaling is selected is  more 
complicated.

Fig. 3.4 
The heavy spot causes a 
vibration peak (minimum gap) 
at time t2. The shaft must rotate 
180° clockwise after the keyway 
passes the phase sensor before 
the high/heavy spot is under the 
proximity probe. The heavy spot 
can be located at 180° counter 
rotation from the probe. 

Fig. 3.5 
The heavy spot causes a 
vibration peak (minimum gap) 
at time t3. The shaft must rotate 
270° clockwise after the keyway 
passes the phase sensor before 
the high/heavy spot is under the 
proximity probe. The heavy spot 
can be located at 270° counter 
rotation from the proximity probe.
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When the phase lag conversion is 
invoked the phase scale is set to a
default of 0° bottom and 360° top.
Simultaneously a complex conjugate
of the data is calculated. The complex
conjugate function changes the sign
of the imaginary portion of the 
complex numbers that are used 
to represent vectors in rectangular
coordinates. The real and imaginary
vectors are at right angles to each
other and are used to uniquely identi-
fy a location in rectangular coordi-
nates. For example, a vector at -30°
on the ±180° scale with a magnitude
of 1.0 is represented by the vectors
0.866 - j 0.5 in rectangular coordinates
(Fig 3.6.) The real part is equal to
0.866, the imaginary part is equal to
-0.5, and j = √−1. The sine wave that
corresponds to this phase angle is
shown in Fig. 3.7 and is the same for
all phase scaling conventions. The
complex conjugate would then be
0.866 + j 0.5 or +30° on the ±180°
scale and the 0° to 360° scale. The
conjugate process can be said to
change the sign of the imaginary 
vector as in Fig 3.6. The taking of the
conjugate of a vector provides the
phase lag conversion. The rescaling
of the phase range from ±180° to 0°
to 360° phase will provide the dis-
plays that are consistent with those
provided by DVFs. Remember, you do
want measurements that are consis-
tent with historical results.

The math is as follows:
φ = {360° - (-30°)} = 390° → +30°

Fig. 3.6
The vector 1 ∠∠-30° 
on the ±180° phase 
scale is represented 
by rectangular 
coordinates 
(0.8666 - j 0.5). 
The complex 
conjugate of this 
vector is 0.8666 + j 0.5. 
This vector maps to 
+30° on both the 
0° to 360° and the 
±180° scales.
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Fig. 3.7
The sine wave 
with a +30° phase 
lag has a peak 
at 1/12 of a 
revolution 
(0.08333 
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(phasor leading 
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Phase Lag Scaling

The first part of the example covers
setting up phase lag scaling in the
35670A with software release A.00.24
and higher. The second part takes you
through the vector math to provide
an intuitive handle on the phase lag
scaling calculation. As an aid in doing
the example, the DSA’s sequence of
commands is called out in a compact
notation. The Front Panel push but-
tons (hard keys) are shown as: 

“Hard Keys”

and the soft buttons, F0 through F9,
are shown as: 

“SOFT KEYS”

A sequence of commands is connect-
ed by “→”. Commands such as 
MARKER ON OFF → ON indicate that 
the function is to be toggled to the
ON state.

Setting up phase lag scaling on 
the 35670A is simply a matter of 
activating the feature.  (Available in
firmware release A.00.24 or higher*.)
Phase lag is implemented as a user-
selected scaling that is applied to 
all subsequent phase coordinate dis-
plays.  To activate the scaling press:

Display format → MORE →
PHASE LAG ON  / OFF → ON

Turning phase lag on will change the
scaling and coordinates for all subse-
quent analyzer measurement modes.

The Phase Lag On can be saved in the
instrument state and then recalled.
When it is recalled, all phase traces
and coordinates will be set to a phase
lag range of 0° to 360° for all other
measurement modes. If the phase lag
scale is the phase convention you
wish to use, then save an Autostate
with Phase Lag On. At power up the
phase lag scale will be activated.

The key path to save an autostate is: 

Save/Recall → SAVE MORE →
SAVE AUTOSTATE

Note: Autostate will also store any other
settings such as displays or input ranges.
Be sure your 35670A is set-up to your 
preferences before storing an Autostate.

The phase scale of 0° bottom, 360°
top is the default phase lag trace
range, but the user can change the
scale to 0° top, 360° bottom. The
command sequence is: 

Scale → TOP REFERENCE → 0 →
BOTTOM → 360

The phase range can be auto-scaled
or an arbitrary range can be set using:

Scale → AUTOSCALE ON OFF → ON or
Scale → TOP REFERENCE and BOTTOM
keys.

All phase plots are labeled PHASE
LAG when phase lag is turned on.
When 

Preset → DO PRESET 

are pressed, the phase lag scaling will
revert to the default PHASE LAG OFF
MODE of scaling (±180°). For the
35670A with older software releases
(A.00.21 or lower), phase lag scaling
can be implemented using the math
function conjugate multiply CONJ( ).
The phase scale is set to 0° bottom
and to 360° at the top. The state with
the phase lag scale and conjugate
multiply math function would be
saved. When recalled, the math and
state/trace can be used to plot phase
lag. The 35670A with software 
rev. A.00.21 or lower will allow a
phase scale of 360° top and 0° bot-
tom, which is the most commonly
used format for phase lag plots. For
the FFT linear resolution and com-
puted order analysis measurement
modes in the 35670A, a separate 
conjugate multiply math function 
for each measurement result that is
to be plotted in phase lag coordinates
will be required.

* To order a firmware update for your 35670A in the USA,
dial 1-800-452-4844 or in Canada 800-387-3154 and ask for
a quote for 35670U Option UE2.  This includes the latest
firmware release and an up-to-date manual set.
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Phase Lag Example

In the example, two simple real-
imaginary data records and the 
conjugate math function are recalled
to illustrate the phase lag scale 
conversion process. 

Insert the disk “Agilent 35670A Rotor
Dynamics MeasurementsTechniques”
into the analyzer.
Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “PHZLAG.STA”.
Press:

RECALL STATE

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL STATE = PHZLAG.STA”.
Press:

ENTER

The state sets up the Order Analysis
measurement mode, display coordi-
nates, and format. The recalled 
state also sets the time and frequency
parameters so the math function op-
erates in sync with the recalled data.

Next, with the disk catalog on the 
display, rotate the marker knob to
highlight the file “PHZLAG.DAT”.
Press:

RECALL DATA → RECALL TRACE AND SCALE
→ FROM FILE INTO D8. 

Verify that “FROM FILE INTO D8 =
PHZLAG.DAT” is in the prompt field
and then press: 

ENTER 

The recalled real-imaginary data will
be used to demonstrate the phase lag
conversion process using the math
function that will be recalled later.

With the disk catalog on the 
display, rotate the marker knob to
highlight file “PHZLG1.DAT” and
press: 

FROM FILE INTO D7 

Verify that the correct file is in the
prompt field and then press

ENTER

Next, with the disk catalog on the 
display, rotate the marker knob to
highlight the file “PHZLAG.MTH”.
Press:

Rtn → Rtn

(the button located just below the
soft key F9) and press:

RECALL MORE → RECALL MATH

Verify that the prompt at the top of
the screen shows “RECALL MATH =
PHZLAG.MTH” and then press: 

ENTER

Press Disp Format key to turn on the
trace display. Press:

Active Trace → D 
Trace Coord → MORE CHOICES →
IMAGINARY PART

The display should appear as in 
Fig. 3.8. The real and imaginary 
values are 866.6 µ inch Pk and 
-j 500 µ inch Pk.

Press: 

Disp Format → SINGLE
Trace Coord → PHASE 

and note the angle readout for 
order 1 is -30° on the ±180° 
phase scale.

Fig. 3.8 
The real and 
imaginary values 
for a vector of 
length 1 ∠∠-30° 
on the ±180° 
phase scale. 
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Next we will put a Nyquist 
Diagram on trace C.

Active Trace → C  
Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM 
Scale → TOP REFERENCE → 1 →
BOTTOM → -1 → milli EXP -3

Note that Real = 866.6 µ inch Pk and
Imaginary = - 500 µ inch Pk. 

We can display this vector in a polar
diagram. Press:

Trace Coord → MORE CHOICES →
POLAR DIAGRAM 
Scale → Y PER DIV DECADES →
0.2 → milli EXP -3

Note that the vector magnitude is
M:1.0005 m inch Pk and the phase 
is 330°.

Next, press 

Active Trace → A 

The A trace contains the sine wave of
one mil Pk that was Fourier Trans-
formed to produce all the spectral
results used up to this point.

Press: 

Marker → MARKER TO PEAK 

and note that the peak value of the
sine wave is at 82.031 m Rev. and the
magnitude is 1.00058 m inch Pk. 

The angular location of the high 
spot for a sine wave peak at this 
location would lag the peak by 30°.
The phase lag calculation: 
φ = 0.082031 X 360° = 29.53° (30°).
The results should appear as 
in Fig. 3.7.

Make the D trace active, press:

Active Trace → D 
Trace Coord → PHASE 

and note that the angle is 
-30° on the ±180° scale. Press:

Analys → DEFINE FUNCTION 

and note that the MATH FUNCTION
F1 = Conj (D8). Next, press: 

Meas Data → MORE CHOICES →
MATH FUNCTION → F1  
Trace Coord → PHASE

Note that the phase readout is now
30° on the ±180° scale. Change to the
0 to 360° scale by pressing: 

Scale → CENTER REFERENCE →
180 → ENTER 

Note that the phase readout is still
30° on the 0° to 360° phase scale.

Next, press: 

Meas Data → MORE CHOICES →
DATA REGISTER → D8 

We are now looking at data which has
not been conjugate multiplied and is
displayed on a 0 to 360° phase scale.
Note that the phase now reads 330°
for order 1. Press:

Scale → CENTER REFERENCE →
0 → ENTER 

and note that the scale is back to
±180° and the angle is still shown 
as -30°.

The previous steps showed in a brief
fashion how to use conjugate math 
to implement phase lag scaling.  
The next few steps require 35670A
Firmware revision A.00.24 or higher.

Press: 

Disp Format → UPPER/LOWER → MORE →
PHASE LAG ON OFF → ON

Note that the D trace phase scale
changes to 0° bottom 360° top and
order 1 shows an angle of +30°. The
vertical axis is now labeled Phase
Lag.  The C trace is now labeled Polar
Lag and shows +30°.

Press: 

Active Trace → AB. 

Note that the sine wave peak and the
phase of the first order in the lower
trace are in agreement.

The phase lag convention can be 
implemented either with the math
function conjugate multiply, or by 
using the phase lag display format 
function on the 35670A.

At this point, the relationship 
between the sine wave and the phase
lag scaling has been illustrated. The
measurement setup for obtaining
accurate phase values from a DSA
requires a once-per-revolution trigger
keyphasor and a vibration signal. In
the Order Analysis measurement
mode, the once-per-revolution
keyphasor is connected to the TACH
INPUT and to the EXT. TRIGGER
INPUT. The DSA resamples a block of
vibration signal data at uniform incre-
mental angles of rotation. The trigger
point should be set up to trigger on
the leading edge of the keyphasor.
The first data point in the data block
(angle 0) starts at the trigger point.
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Eddy current proximity probes are
widely used vibration sensors found
on critical process machine assets.
The probes sense the gap between
the probe tip and the rotating surface
of a shaft by inducing an eddy current
in the conductive surface of the shaft.
The probes ideally would produce a
signal caused only by the dynamic
motion of the surface passing under
the probe tip.  However, these trans-
ducers produce signals caused by
shaft surface conductivity variations
as well as those caused by shaft 
dynamics.  The dynamic signals of
interest can be distorted or lost in the
signals caused by the “bumps” on the
shaft.  These unwanted shaft-related
gap signals can come from several
sources.  The largest signal is usually
due to the shaft center of rotation
being offset from the shaft center.
Other contributors include normal
machining imperfections such as 
out of round, tool chatter marks, etc.
These can produce rather large varia-
tions in eddy current.  Other sources
of unwanted signals are variations 
in shaft plating thickness, hardness
variations and surface cracks and
scratches.  Damage due to mishan-
dling during repair can produce sig-
nals that make before-and-after repair
comparisons difficult.  The American
Petroleum Institute considers 
0.25 mils peak-peak or less radial
runout to be acceptable.  In general,
the measured dynamic signal should
be 20 or more times larger than the
shaft surface-related signals for 
measurement errors and distortion 
to be at acceptable levels (Fig. 4.1).
Distortion of 5% or less in the order

histories and orbits are barely visible
(Fig. 4.2).  This 20:1 signal-to-noise
margin cannot always be met.  To
correct for these errors, a technique
known as slow-roll removal has
evolved.

Slow roll removal was first imple-
mented using a DVF by subtracting
offsets within the meter.  The slow
roll removal process started with the

capture of 100 or more gap vectors
for one revolution at a low speed
with a DVF.  Since the vectors are
acquired at uniform angular incre-
ments, the slow roll could then be
subtracted out of all order records
captured at higher RPM.  The DVF’s
tunable tracking filters would be set
up to remove the first order slow roll
from the unfiltered order records.
The slow roll was difficult to remove

Section 4
Slow Roll Removal From 
Order Records

Fig. 4.1 
Two order data 
records, one with 
±20% slow roll 
noise added, are 
superimposed.  
Two order data 
records are 
superimposed.  
One is an ideal 
record, the 
second one 
has 20% slow 
roll noise added.  
This is an 
unacceptable 
amount of noise.
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Fig. 4.2 
An ideal first 
order data record 
superimposed 
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±5% noise added.  
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for higher orders.  The process was
time consuming and tedious so it 
was usually done “off line” using
tape-recorded data. 

The waveform math capabilities 
of the Agilent DSA make slow roll
removal much easier.  The DSA Order
Analysis measurement mode is first
set up with an order resolution of one
order.  Under these conditions the
DSA displays exactly one revolution
per record (Fig. 4.3).  Typically, a
measurement with one average at 
a low RPM is set up, and the X and Y
slow roll signal records are measured
and then saved in data buffers.  Using
math functions it is easy to subtract
the slow roll order record from all
higher RPM order data records in the
data capture buffer.  The simple math
function for the 35670A is shown.

F1 = (TIME1- D1)
F2 = (TIME2 - D2)

In this example Data registers D1 and
D2 contain the slow roll records of
the X and Y proximity probes.  Times
1 and 2 are the order data records
from channels 1 and 2.  The slow roll
measured by the 35670A can include
from 0.025 to 200 orders that are user
selectable.  The slow roll removal 
and display of live corrected order
records as they are measured is a
one-step operation (Fig. 4.4 and 4.5).
The example at the end of this 
section provides the step-by-step 
procedures for slow roll removal
using the 35670A.  This example uses
300 RPM on a rotor kit.  Your slow
roll RPM may be different.
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Fig. 4.4
The X probe 
order records 
of uncorrected 
and slow roll 
corrected data 
overlaid at 
6000 RPM.  
Removing the 
static values 
shows the 
dynamic 
behavior.

Fig. 4.5
The Y probe 
order records 
of uncorrected 
and slow roll 
corrected data 
overlaid at 
6000 RPM.  
Removing the 
static values 
shows the 
dynamic 
behavior

Fig. 4.3 
The slow roll 
X-Y data records 
measured at 
300 RPM.  
These changes 
in gap distance 
are static (Not 
related to speed)
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Example: Slow Roll Removal from
Order Records

Slow roll removal from order records
has three conceptual steps.  First, the
slow roll behavior must be measured.
In our example you will extract this
from stored rotor kit run-up data.
Next the math functions which 
subtract the slow roll characteristics
from live measurements must be 
defined.  In our example you will 
recall measurement state parameters 
to set these functions up.  Finally, the
actual high speed rotor measure-
ments are made and the corrected 
results displayed.

In our supplied example data the
slow roll measurements are made at
300 RPM.  The slow roll measurement
takes advantage of averaging in the
analyzer.  For the actual dynamic
shaft measurements it is important to
note that the rotor kit used for this
data has very little dynamic response
below 3000 RPM.  You’ll be instructed
to turn off averaging and to manually
change the start speed to 3000 RPM
and the stop speed to 8000 RPM.  By
triggering the measurement on larger
RPM increments (increasing the RPM
step size) you can speed up the meas-
urement.  RPM step arming will be
used to allow you to control the 
exact trigger conditions of each
measurement.

The example, using the supplied 
capture data, is intended to be a
guide for your use.  You would use
similar techniques to make measure-
ments from tape recorded data, rotor
kits or directly from probes on an
operating machine.

Recalling the Data, State, and Math

The slow roll removal example starts
by doing a preset.  Press: 

Preset → DO PRESET 

The runup data, measurement state
and math functions are recalled next.
Insert the disk “Agilent 35670A Rotor
DynamicsMeasurements Techniques”
into the analyzer.
Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “RNUPAC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE.

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL CAPTURE =RNUPAC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “SLOROL.MTH” and
then press:

Rtn
RECALL MORE
RECALL MATH

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL MATH = SLOROL.MTH”.  
Press:

ENTER

Rotate the marker knob to highlight
the file “SLORL1.STA”. 
Press:

Rtn
RECALL STATE

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL STATE = SLORL1.STA”.
Press:

ENTER
Disp Format
Start 

The DSA will begin a measurement
on the captured rotor data you just
recalled.  The tach readout at the top
of the screen will increment up to 
approximately 300 RPM and the 
X and Y slow roll proximity probe
waveforms will appear in the A and B
traces with the markers on their re-
spective peaks.  The screen should
match the data in Fig. 4.3.  This 
is your measurement of slow 
roll properties.

The next step is to store the slow roll
properties for use in correcting
dynamic measurements.  The X-Y
slow roll data will be saved in data
registers D1 and D2.  Press: 

Active Trace → A → Save Recall →
SAVE DATA → SAVE TRACE → INTO D1 
Active Trace → B → SAVE TRACE →
INTO D2
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Modifying the 
Measurement State

The order analysis state will now be
modified to measure from 3000 to
8000 RPM.  The data display will be
set up to show the results of the
uncorrected order data overlaid with
the slow roll corrected data.
Press: 

Avg → AVERAGE ON OFF → OFF

The measurement will be set to start
at 3000 RPM and to stop at 8000 RPM.
The RPM step size will be increased
to 40 RPM to speed up the 
measurement. 

Freq → MIN RPM → 3000→ RPM →
MAX RPM → 8 → KRPM
Trigger → ARM SETUP → RPM STEP ARM
→ RPM STEP SIZE → 40 → RPM

The display is set up to display the
math function results.  Press: 

Active Trace → A 
Meas Data → MORE CHOICES →
MATH FUNCTION → F1 
Active Trace → B → F2
Active Trace → A B 
Trace Coord → MORE CHOICES → REAL PART
Start

to begin the measurement.  The tach
display will start incrementing up and
when it reaches 3000 RPM, the slow
roll corrected data will appear on the
screen.  The slow roll correction will
continue to update every 40 RPM and
stop at approximately 8000 RPM.  The
last measurement at 8000 RPM will
appear fixed on the screen.

Display Trace Setup

The following key sequence sets 
up the display so that the slow roll
corrected and raw data can be com-
pared.  The trace setup to display
uncorrected X probe data in the B
trace is as follows:
Press: 

Disp Format → QUAD  
Active Trace → B 
Meas Data → TIME CHAN 1

Trace setup to display the slow roll
corrected data for the Y probe in
trace C is:

Active Trace → C 
Meas Data → MORE CHOICES →
MATH FUNCTION → F2 

Trace setup to display uncorrected 
Y-probe data in trace D is:

Active Trace → D
Meas Data → CHAN 1 2 3 4 → 2 →
TIME CHAN 2

All four traces will be set to display
coordinates Real versus 1 rotation
and to autoscale their data.

Active Trace → A B C D 
Trace Coord → MORE CHOICES → REAL PART
Scale → AUTO SCALE ON OFF → ON →
OFF

Turning autoscale on, then off, forces
a one time rescaling of the display.

Next set up a front back (overlaid)
display of the slow roll corrected 
and uncorrected X data.  The X probe

data will be in traces A and B, the 
Y probe data will be in traces C and D.

Active Trace → A B
Marker → COUPLED ON OFF → ON →
MARKER TO PEAK
COUPLED ON OFF → OFF 
Active Trace → C D →
MARKER TO PEAK
Disp Format → SINGLE FRNT/BACK
Active Trace → A B 

This displays the corrected and
uncorrected X probe data.  Note that
the slow roll corrected X probe data
trace is about 0.64 mils less than the
uncorrected X order data record 
(Fig. 4.4).

The Y probe uncorrected and
corrected data are examined by 

making the C trace active. 

Active Trace → C D

The results will be very similar to 
Fig. 4.5.  Note that the slow roll cor-
rection is approximately 0.378 mils.
The smooth shaft on the rotor kit 
produced only a small slow roll error.
The slow roll correction did not 
produce significant effects until the 
dynamic response began to grow at
3000 RPM.  The first 10 orders were
removed in one pass.  Since this ap-
proach is not correcting one order at
a time as is possible with a DVF, the 
results you will see are going to be a
little different.  When a slow roll
record is subtracted from a higher
RPM record that is only slightly larg-
er, the difference will be dominated
by noise. 

A detailed step-by-step key 
sequence is provided as a 
reference in Appendix A.
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Orbits, or X versus Y displays of 
shaft position change versus angle 
of rotation, were first measured by
placing a needle point on a turbine
shaft end and then observing the
motion with a microscope.  This dis-
covery from the 1930’s was replaced
long ago by pairs of proximity probes,
Digital Vector Filters and an oscillo-
scope.  (Figure 5.1)

Orbit displays give a two dimensional
visual picture of the motion of a
rotating shaft.  Just like order meas-
urements, orbits can be contaminated
by shaft related “noise.”  Removing
the noise using slow roll compensa-
tion techniques greatly improves the
quality of orbit data.  The advantages
of slow roll correction were covered
in Section 4 of this note.

The 35670A has built-in orbit displays,
but these are limited to raw time 
or order data records.  The standard
orbit display can not be used to 
show slow roll corrected orbits.
Fortunately, the Agilent DSA has
another display type which can be
used to show an orbit, the Nyquist
Diagram.  The Nyquist Diagram 
displays real versus imaginary data,
so we must go through two simple
steps to get a slow roll corrected
orbit.  First, we must calculate the
slow roll corrected data.  Second, we

must multiply the corrected Y data 
by the complex number (0+1j) to put
it on the Nyquist diagram imaginary
axis.  The imaginary axis (Y) probe 
is +90° from the real axis (X).  Thus
the two displays are equivalent 
representations.

The math function is as follows:
F3 = (TIME1 - D1) + 
K4 * (TIME2 - D2)

The slow roll X and Y data are saved
in data registers D1 and D2.  K4 is the

complex constant (0 + j1).  Times 
1 and 2 are the live order records.
Multiplying the corrected Y data by 
(0 + j1) converts the Y data record
from real values to imaginary values.
Then the X real data are added to 
the Y imaginary data to produce one
record of the combined corrected 
X-Y order.  The last step is to set up a
Nyquist (or polar diagram) to display
the results of the math function F3
(Fig. 5.2). 

Section 5
Slow Roll Removal 
From Orbits
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Fig. 5.1 
A block diagram of 
a typical DVF set up 
to measure and 
display an orbit. 

Fig. 5.2 
A corrected orbit 
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the Nyquist trace 
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the Agilent 35670A.

+j

-j

+1-1

B: F3 (TIME1-D1) X:0 RevR:-2.325 m* I:-1.012 m*

Real-5.063m* 5.063minchpk

4
minchpk

-4
minchpk

Imag
Nyquist

800
uinchpk

/div

Disp Frmat



21

Example: Slow Roll Removal 
From Orbits 

The example of slow roll removal
from orbits uses the math and time
capture files from the example in
Section 4 above.  The X-Y order
records are combined into one data
record for display.  The standard orbit
display is selected with the ORBIT 2/1
under the Meas Data key.  The orbit
display works with time records in
the FFT mode or order records 
in the order analysis mode.  To 
display slow roll corrected orbits, 
we make use of a math function to
combine the X-Y data and use the
Nyquist Diagram display coordinates
to view the results.  As in the last
example, the X-Y slow roll is mea-
sured at 300 RPM and saved in data
registers D1 and D2.  The math func-
tion takes the current order record
for each probe and subtracts the slow
roll correction.  The Y axis data is
multiplied by (0 + 1j) to move it to
the imaginary axis.  The X and Y data
are then combined to make a com-
plex number (real + imaginary) pair.

Verify Data Setup

If the DSA has not been powered
down since the completion of the
example in Section 4, then the time
capture and math files should still be
in memory.  You can check by view-
ing the time capture buffer and the
analysis portion of the 35670A.  To
display the time capture buffer, press:

Active → AB → Meas Data →
ALL CHANNELS → CAPTURE CHANNEL* 
Disp Format → UPPER/LOWER → Scale →
AUTOSCALE ON OFF → ON → OFF

If the runup data do not appear on
the screen, then the time capture,
state, and math records of the Section
4 example will need to be recalled.
To verify the math, press: 

Analys → DEFINE FUNCTION 

and compare F3 in the DSA to:
F3 = (TIME1 - D1) + 
K4*(TIME2 - D2)
K4 = 0.0000 + j

1.0000

Next, verify that data registers D1 and
D2 contain the slow roll data. 
Press: 

Meas Data → MORE CHOICES →
DATA REGISTERS → D1 →
Active Trace → B → D2

The display will be the same as 
(Fig. 5.3).

If the data and math are still in the
35670A memory, proceed to the sec-
tion titled “Recall Measurement State
SLORL2.STA.” You can check the
time buffer contents by pressing:

Active Trace → AB
Meas Data → ALL CHANNELS →
MORE CHOICES → TIME CAPTURE*
Scale
AUTOSCALE ON/OFF → ON → OFF

If no time capture data appears 
on the traces, you will need to
reload the file.

Fig. 5.3 
The X and Y 
slow roll records 
in data registers 
D1 and D2. 
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Recalling Data

Insert the disk “Agilent 35670A Rotor
Dynamics Measurements Techniques”
into the analyzer.
Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “RNUPAC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE.

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL CAPTURE =RNUPAC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “SLOROL.MTH” and then
press:

Rtn
RECALL MORE
RECALL MATH

Verify that the prompt at the top of
the analyzer screen shows
“RECALL MATH = SLOROL.MTH”.  
Press:

ENTER

Rotate the marker knob to highlight
the file “SLORL1.STA”. 
Press:

Rtn
RECALL STATE

Verify that the prompt at the top of
the analyzer screen shows
“RECALL STATE = SLORL1.STA”.
Press:

ENTER
Disp Format
Start 

The tach readout at the top of the
screen will increment up to approxi-
mately 300 RPM and the X and Y slow
roll proximity probes waveforms will
appear in the A and B traces with the
markers on their respective peaks.

Now save the X-Y slow roll data in
registers D1 and D2.
Press: 

Active Trace → A  
Save Recall → SAVE DATA →
SAVE TRACE → INTO D1
Active Trace → B 
SAVE TRACE → INTO D2

Recall Measurement State
SLORL2.STA

Press: 

Save/Recall → CATALOG ON OFF → ON 

and rotate the marker knob to high-
light the file “SLORL2.STA”. Press: 

RECALL STATE

and verify “RECALL STATE =
SLORL2.STA,” and then press: 

ENTER
Disp Format 
Start
Scale → AUTOSCALE → ON / OFF → ON  

The tach display will begin to 
increment up.  At about 3000 RPM
two orbits will become obvious on
the display.  The slow roll corrected
orbit is the inner one, and the outer
orbit is the raw X versus Y data.  The
marker was set at 0.00 revolutions,
which corresponds with the phasor
leading edge, and the record length is
0.984375 revolutions.  The combina-
tion of the markers at 0 revolutions
and the record length being about
1.5% short of a full revolution pro-
vides the bright spot, blank spot that
is similar to the one provided by a
DVF.  However, the marker must be
set at 0 revolutions and not moved
while the orbits are being displayed.
The last orbit should appear near 
6000 RPM and will look like (Fig. 5.4).
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Press: 

Scale → AUTOSCALE → ON / OFF → OFF
Disp Format → UPPER LOWER 

This separates the overlaid traces.
The upper trace is the default orbit
2/1 display and the lower trace is the
slow roll corrected orbit displayed in
a Nyquist Diagram.  

Next, the slow roll corrected 
X -Y order records will be viewed.
Press: 

Active Trace → CD 
Marker → MARKER TO PEAK

The upper trace is the corrected 
X probe data ,the Real part, and 
the lower trace is the corrected 
Y probe data, the Imaginary part,
from the math function F3 
(Fig. 5.5).

Next, we will increase the test speed
range to start at 5000 RPM and end at
8000 RPM.  Press: 

Freq → MIN RPM → 5 → KRPM →
MAX RPM → 8 → KRPM 
Active Trace → AB 
Disp Format → SINGLE FRONT/BACK
Scale → TOP REFERENCE
55 → BOTTOM → -5 → MILLI-EXP-3
Start

The tach display will indicate a 
run-up is in progress.  At 5000 RPM,
the first orbits will appear and will
continue to update until 8000 RPM 
is reached.  The 35670A can display
two live orbits and two slow roll 
corrected orbits with the optional
four analog inputs.

Manual Setup

The manual setup of the Measure-
ment State for this example is a small
extension of the example in Section 4.
Refer to Appendix A for the detailed
setup key sequences. 

Fig. 5.4 
The slow roll 
corrected orbit 
is the inner orbit.  
The outer orbit 
is the uncorrected 
X versus Y data.  
The combination 
of the markers 
at 0 revolutions 
and showing 98% 
of a full revolution 
provides the 
bright spot, blank 
spot that will 
be familiar to 
DVF users.
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Fig. 5.5 
Order records 
for the X and Y 
probes.  These 
are calculated 
by math function 
F3 and are viewed 
by displaying the 
real part, for the 
X data and the 
imaginary part 
for the Y data.
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Proximity probes cannot easily be
mounted in the desired horizontal
and vertical orientation due to bear-
ing split lines and interference of oil
lines, etc.  As a result, X-Y probe 
pairs are often encountered that are
rotated from the ideal horizontal and
vertical position (Fig. 6.1).  The probe
pair in Fig. 6.1 is rotated +45° from
true horizontal and vertical. On many
machinery trains, several different
probe pair orientations may be en-
countered (Fig. 6.2).  If you want to
compare orbits along a machinery
train with different probe orienta-
tions, you must rotate the orbits back
to a common horizontal and vertical
position.  The rotation correction is
very critical when the measurement 
results are to be communicated 
clearly to others and when 
multi-plane balancing is done.

The default orbit displays and 
Nyquist Diagram trace coordinates 
in the 35670A assume the measured
and slow roll corrected data that go
into orbits are from probes that are
oriented in horizontal and vertical 
positions.  For the data in this note
Channels 1 and 3 measure from the 
X probes (horizontal orientation) and
channels 2 and 4 measure from the 
Y probes (vertical orientation).  

The orbit and Nyquist Diagram trace
coordinates cannot be rotated to 
correct for proximity probe pairs that
are rotated from true horizontal and
vertical.  However, the trace coordi-
nate polar diagram is easily rotated
using the POLAR ROTATE function.

Section 6 
Orbit Rotation to 
Horizontal and Vertical

View from drive end of the shaft

Y Proximity
Probe

X Proximity
Probe

E F

90°
45° 45°

X

Y

X Y

G H

90°
45°

45°

XX

Y

Y

A B

90°
45°45°

X

Y

XY

C D

90°
45°

45°

XX

Y

Y

Fig. 6.2 
Radial proximity 
probe pair angular 
locations and 
identification 
commonly found 
on machinery*. 

Fig. 6.1 
Proximity probes 
are seldom mounted 
on machines in the 
ideal horizontal 
and vertical 
orientation.  
The probe pair 
shown are rotated 
+45° from 
horizontal 
and vertical.

* Figure courtesy of  Machinery Malfunction Diagnosis and
Correction, Vibration Analysis and Troubleshooting for the
Process Industries, Robert Eisenmann Sr. P.E. & Robert
Eisenmann Jr. PTR Prentice Hall, Nov. 97. , chapter 6
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If data were acquired from a 
probe pair like those in Fig. 6.1, the
resulting orbit would be rotated 
+45° from true horizontal and verti-
cal.  The correction would require 
a rotation of the orbit data by -45°
(Fig. 6.3).

Example: Orbit Rotation

If the time capture data is still in
memory, it is not necessary to recall
it again.  You can use the technique in
Section 5 (Pg. 21) to display the time
buffer.  Otherwise you will need to 
recall the file again.  

Recalling Data

Insert the disk “Agilent 35670A Rotor
Dynamics MeasurementsTechniques”
into the analyzer.

Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “RNUPAC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE.

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL CAPTURE =RNUPAC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “SLORL1.STA”. 
Press:

RECALL STATE

Fig. 6.3 
The angular 
transducer 
positions are 
rotated relative 
to the display 
coordinates as 
shown.  The 
correction is 
made by 
rotating the 
display +45° 
or rotating the 
data -45° as in 
this case*.  

Vertical
or Y Input

Oscilloscope
Vertical
or Y Input

Horizontal
or X input

Oscilloscope
Horizontal
or X input

Probe
Y-axis

Probe
Y-axis

True
Vertical
(up)

True
Vertical
(up)

Probe
X-axis

Probe
X-axis

True
Horizontal
(right)

True
Horizontal
(right)

* Figure courtesy of  Machinery Malfunction Diagnosis and
Correction, Vibration Analysis and Troubleshooting for the
Process Industries, Robert Eisenmann Sr. P.E. & Robert
Eisenmann Jr. PTR Prentice Hall, Nov. 97. , chapter 6
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Verify that the prompt at the top 
of the analyzer screen shows
“RECALL STATE = SLORL1.STA”.
Press:

ENTER
Disp Format
Start

The tach readout will increment up 
to approximately 300 RPM and the 
X and Y slow roll proximity probe
waveforms will appear in the A and B
traces with the markers on their
respective peaks. 

Set up an orbit display by pressing:

Disp Format → SINGLE
Meas Data → ORBIT 2/1  
Marker → MARKER ON/OFF → ON →
COUPLED ON/OFF → ON →
MARKER X ENTRY → 0 Rev. 

Your display should now look like
Fig. 6.4.  Now press:

Active Trace → B
Meas Data → ORBIT 2/1
Trace Coord →MORE CHOICES →
POLAR DIAGRAM  
POLAR ROTATION → -45 → DEGREES

The trace B display should now look
like Fig. 6.5.  Note that the marker
readout on the polar diagram is now
a vector magnitude and angle.  
Selecting POLAR DIAGRAM does a
rectangular to polar conversion 
(magnitude/angle).

Fig. 6.4 
A The orbit 
measured here 
is assumed to 
have come from 
probe pairs 
positioned 
rotated +45° 
horizontal 
and vertical. 
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Date: 08-14-97 Time: 03:41:00 PM

Fig. 6.5
Polar rotation of 
- 45° was applied 
to the data in 
(Fig. 6.4) to 
re-orient the 
orbit to true 
horizontal and 
vertical 
coordinates.
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A Bodé plot is a graph of magnitude
and phase versus speed or frequency.
In rotor dynamics a Bodé plot usually
graphs the magnitude and phase of a
specific order versus RPM (Fig 7.1)
The Bodé plot is used to help identify
rotor critical speeds and to examine
rotor dynamics on an order by order
basis.  Shaft measurement anomalies
can obscure and mask the dynamic
behavior of order track measure-
ments just as they do with orbits.
Slow roll compensation of Bodé 
plots evolved to enhance the results
by removing the slow roll errors so
that only the dynamic response was
displayed. Slow roll compensation is
done by subtracting out the slow roll
vector from the Bodé plot over the
speed range of the measurement.

In the example at end of this section,
a first order Bodé plot is extracted
from a 300 to 8000 RPM runup.  The
marker is used to enumerate the 
Real and Imaginary values of the slow
roll vectors at 300 RPM.  Values are
entered into the math constants K1
and K2 for X-Y probe data.  The slow
roll vector is subtracted from all 
subsequent RPM points using the
math functions. 

F1 = (track 11 - K1)
F2 = (track 12 - K2)

The 35670A can measure magnitude
and phase versus RPM on five orders
simultaneously, and can have four 
input channels on line at one time.
Slow roll compensation can be
applied to the Bodé plot data as 
the machine is tracking the speed
ramp-up or the compensation can 
be applied after the Bodé plot is 
completed.  In the example, the 
compensation is applied after the

Bodé plot is completed.  The slow 
roll compensated Bodé plot of 
Fig. 7.2 results from displaying the
math function and selecting the
Phase Lag scale.

Example: Slow Roll 
Compensation of Bodé Plots

The compensation of a Bodé plot
begins with measuring the slow roll
vector.  The vector is subtracted from
all higher RPM vectors.  The slow roll

compensation can be applied as the
machine is ramping up in speed or 
after the startup transient has been
captured.  In this example, the com-
pensation is applied to an order track
extracted from a runup transient that
was throughput to the time capture
buffer.  The example exercise walks
you through compensating the first 
order.  The 35670A measures four
additional orders that you may wish
to compensate.  The example begins
with recalling a time capture file, a

Fig. 7.1 
A first order 
Bodé plot from 
a rotor kit.  
Magnitude and 
phase versus RPM 
were extracted 
from a run-up 
capture.  
The trace 
coordinates 
were set up 
by selecting 
magnitude 
pk-pk on the 
A and C traces 
and phase lag 
on the B and D 
traces.
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Fig. 7.2 
The compensated 
Bodé plot of 
Fig. 7.1 was 
slow roll 
compensated 
over the speed 
range of 300 to 
6000 RPM by 
a slow roll 
vector measured 
at 300 RPM.
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Section 7
Slow Roll Compensation 
of Bodé Plots
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measurement state, and a math func-
tion.  You are walked through the
steps to measure, extract, and enter
the slow roll vector into the math
constants and view the compensated
results.  Next, the display is set up
manually to compare the measured
and compensated Bodé plots.

Recalling the Setup 

Note: If the time capture data is still in
memory, it is not necessary to recall it
again.  You can use the technique in
Section 5 (Pg. 21) to check the contents 
of the time buffer.  You will need to recall
the state and math files for this section.

Insert the disk “Agilent 35670A Rotor
Dynamics Measurements Techniques”
into the analyzer.  
Press:

Save / Recall →→ CATALOG ON / OFF -> ON

Rotate the marker knob to highlight
the file name “RNUPAC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE.

Verify that the prompt at the top of
the analyzer screen shows “RECALL
CAPTURE = RNUPAC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “BODE.STA”.  
Press:

Rtn
RECALL STATE
ENTER

Rotate the marker knob to highlight
the file “BODE.MTH” and then press:

Rtn
RECALL MORE
RECALL MATH

Verify that the prompt at the top 
of the analyzer screen shows 
“RECALL MATH = BODE.MTH”.  
Press:

ENTER
Disp Format
Start

to measure the Bodé plots for 
orders 1 through 5 on the X and 
Y probes. 

As the measurement proceeds, the
tracking markers will read out each
measurement point on all four traces
(Fig. 7.1). The A and C traces are the
linear magnitudes in mils PP.  The B
and D traces are order 1 phase for the
X-Y probes.

To view the higher orders that were
also measured (orders 2 through 5)
press:

Active Trace → AB 
Meas Data → ALL CHANNELS →
MORE CHOICES → ORDER TRK CHAN * →
TRACK 2 ORD 2.0 →
Scale → AUTOSCALE ON OFF → ON 

Next select track 3 through track 5
and back to track 1 ORD 1.00
With the A and B traces displaying
track 1, press: 

Scale → TOP REFERENCE → 12 →
BOTTOM → 0 → milli EXP-3 
Marker → COUPLED ON OFF → ON →
MARKER ENTRY → 300 → RPM 
Disp Format → UPPER LOWER  

Both the A and B traces should still
be active.  Press: 

Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM

At the top of each trace, the slow 
roll Real and Imaginary values at 
300 RPM are displayed (Fig. 7.3). 

Fig. 7.3 
The Nyquist 
diagram of 
order 1 of the 
X-Y probe data 
provides the 
easiest way of 
extracting the 
Real-Imaginary 
values for slow 
roll correction. 
Note: the marker 
readout at the 
top of each trace 
displays the real
and imaginary
values directly.
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Copy the values in the space 
provided.  (Be sure the marker is at
300 RPM.)
A: CH1 ORD1 
R:  ______________EXP __________
I:  ______________EXP __________
X: 300 RPM
B: CH2 ORD2 
R:  ______________EXP __________
I:  ______________EXP  __________
X: 300 RPM 

The Real and Imaginary values will be
entered into the waveform math con-
stants K1 for the X probe and K2 for
the first order Y probe data.
F1 = (TRACK11 - K1)
F2 = (TRACK12 - K2)
Press: 

Analysis → DEFINE CONSTANT 
K1-K5 → DEFINE K1 →

Using the numeric keypad enter the
real and imaginary numbers.
Real:

_________ EXP ____ → +J →
+/– → – →
________ EXP __DEFINE K2 →
ENTER REAL & IMAG. PARTS
+/– → _______ EXP ___ → +J →
+/– → __________ EXP ___

Next, the slow roll compensated and
uncompensated Y first order data will
be overlaid and compared.  Make the
C trace active by pressing: 

Active Trace → C  
Meas Data → MORE CHOICES →
MATH FUNCTION → F2 
Active Trace → CD  
Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM 
Disp Format → SINGLE FRONT BACK  
Scale → TOP REFERENCE → 5 → BOTTOM
→ -1 → milli EXP-3 

The coupled markers should still 
be active and at 300 RPM.  The com-
pensated and uncompensated first
order Y probe results are overlaid in
the Nyquist Diagram.  The two Real-
Imaginary data pairs at 321 RPM are
displayed at the top of the traces.
Evaluate the differences in Real-
Imaginary values on the traces 
(Fig. 7.4).

Next, the X probe data will be com-
pared.   Press: 

Active Trace → B 
Meas Data → MORE CHOICES →
MATH FUNCTION → F1  
Active Trace → AB 
Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM
Display Format → SINGLE FRONT BACK
Scale → TOP REFERENCE → 4 → BOTTOM
→ -4 → MILLI EXP-3

Evaluate the two traces at 
300 RPM as in Fig. 7.5.
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Fig. 7.5 
Nyquist Diagram
overlay of first
order X probe
data.  These
show the slowroll 
compensated and 
uncompensated
data. Note that 
the subtraction 
of the slow roll 
vector has set 
the Real and 
Imaginary values 
at 321 RPM to 
very near the 
origin 0.0 + j 0.0.

Fig. 7.4 
Nyquist Diagram
overlay of first
order Y probe
data.  These
show the slow roll 
compensated and 
uncompensated
data.
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Compensated Bodé Plot

You have now entered sufficient
information to view compensated and
uncompensated Bodé plots.

Press: 

Freq → MIN RPM → 800 → RPM  

This changes the running range of the
meaurements.

Note that the subtraction of the slow
roll vector has set the Real and
Imaginary values at 321 RPM to very
near the origin 0.0 + j 0.0.  A new
measurement start speed of 800 RPM
will illustrate how slow roll compen-
sation can correct the order tracks as
they are measured.  The uncompen-
sated and compensated Bodé plots
will be overlaid and compared.

Now, change the display to linear
magnitude.  Press: 

Trace Coord → LINEAR MAGNITUDE →
Y UNITS → AMPLITUDE Pk PP RMS → PP 

Scale → TOP REFERENCE → 12 →
BOTTOM → 0 → MILLI EXP-3
Start

The results of (Fig. 7.6) will appear
on the screen.

Press: 

Trace Coord → PHASE 
Scale → CENTER REFERENCE → 180 

Compare the compensated and 
uncompensated phase of the Bodé
plots on the DSA and Fig. 7.7.  The
slow roll compensation of an order
track is done on each order with its
unique slow roll vector.  For example,
using this technique, you could enter
the real and imaginary values for the
2nd order.  A math function for the
2nd order would be used to display
corrected 2nd order magnitude 
and phase.

Fig 7.7  
A Bodé plot 
overlay of 
the slow roll 
compensated and
uncompensated 
phase data from 
the X probe.

Fig 7.6  
A Bodé plot 
overlay of 
the slow roll 
compensated and 
uncompensated 
magnitude data 
from the X probe.  
Note the 
compensated 
1st order 
magnitude is 
lower.
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The measurements of shaft center
line position changes are commonly
used to investigate shifts in a
machine’s shaft center of rotation.
These may be due to thermal effects,
load changes, oil temperature, RPM,
preloads, etc.  These measurements
are used to document a machine’s be-
havior during startup commissioning
and to monitor shaft position changes
during heat soaks.  The DC gap volt-
ages from X-Y proximity probes are
sometimes logged along with oil and
case temperature, oil pressure and
RPM.  The data can then be plotted
versus time, temperature, and/or RPM
to document how the journal posi-
tions are related to other machine 
variables.  

The shaft center line measurements
are typically done manually, with an
integrating digital voltmeter that has
5.5 digits of resolution and an accura-
cy on that same order.  The integrat-
ing voltmeter requirement comes
from the need to “integrate” out the
AC signals, due to the dynamics of
the rotor and AC line frequency noise.
The raw voltage data are manually
entered into a PC spreadsheet where
the change in gap can be referenced
to the at-rest gap voltages and plotted
versus other variables.  The proximity
probe scale factors are applied to the
change in voltage readings.  The read-
ings are generally taken on a one- to
four-hour time interval so the data
can be logged manually.  Ideally, shaft

center line position measurements
should be acquired on every startup.
However, measuring shaft position
changes during a fast startup tran-
sient requires a high-speed data
acquisition instrument.  Until recent-
ly, these scanning digital integrating
voltmeters were expensive and
required additional software to 
get the data to a PC spreadsheet.

The low-cost 34970A Data Logger can
automate the measurement of voltage
and scaling to engineering units.  This
data logger can be set up to capture
and scale readings of gap voltages,
temperatures, and pressures at user-
specified time intervals.  The scaled
gap and other readings are easily
transferred to the PC spreadsheet 
via IEEE 488, or RS232 I/O using the
software supplied with the data log-
ger.  The 34970A data logger supports
a variety of scanned input cards in-
cluding thermocouple, a counter/time
interval card for RPM logging, and
four-wire resistance measurements
for scaled strain gauge measure-
ments.  The data logger can scan at
250 readings per second and hold
50,000 time-stamped readings 
in its non-volatile memory.  Even at
250 readings per second, there are
fast startup transients that this unit
would have difficulty tracking.

The 35670A DSA measures shaft 
center line as a standard capability of
the computed order tracking option.
An order track on order 0 for the X-Y
probes is the starting point.  The zero
order data (DC) contains the mean
position values with the higher order
vibration signals “integrated” out.
The Agilent DSA can extract the cen-
ter line position change versus RPM
on fast runup transients, which can
also be done with the data logger
approach for moderate speed ramp
rates.  When the shaft center line
needs to be monitored for longer
times such as during heat soaks, the
DSA measurement arming is changed
from RPM increment to time incre-
ment.  The time increment arming
can be set to range from milliseconds
to hours.  The measured gap values
can come directly from the analog
inputs or the transient data can be
captured and post processed. 

The display of the results in Fig. 8.1 
A and B are the X-Y probe results.
The X-Y data can be combined in
Nyquist Diagram or polar coordinates
to provide an axial view of the shaft’s
X-Y position change as a function of
RPM (Fig. 8.2).  The X data can be
viewed by selecting Real trace coordi-
nates as in Fig. 8.3.  The Y position

Section 8 
Shaft Center Line versus 
Speed or Time
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change data can be viewed by 
selecting Imaginary coordinates as in
Fig. 8.4.  With the order tracking mea-
surement approach, you also have 
the advantage of getting up to four
additional orders from the one pass
through the data.

The computed order analysis soft-
ware option can measure the shaft
center line data by tracking order
zero.  However, the change in center
line position from the shaft’s at-rest
position is the desired result.  Again,
waveform math is used to extract and
format the change in shaft center line
position versus RPM or time.  The
waveform math subtracts the shaft’s
at-rest center line position from each
RPM value.  These X and Y “static”
gap change values are combined into
one data record of orthogonal data
pairs as was done in the slow roll
removal example.  

In this shaft centerline example a 
single waveform math function 
below does the calculation:

F5 = ((Track51/K2) -
K1) + 
K4*((Track52/K2) - K3)

Track 51 and track 52 are the mean
(order 0) X and Y gap in mils Pk ver-
sus RPM (Fig. 8.1 A and B).  Order
track register 5 is assigned to track-
ing order 0 for channels 1 and 2.  The
track 0 data in the DSA are two times
their true value, and thus divided by
K2 (K2 = 2), which scales the track 0
values back to their true values in
mils.  The at-rest X gap value in mils
Pk is entered into constant K1 and
the Y at-rest value in mils is entered
into K3.  The subtraction of the at-
rest X-Y values from the remaining

Fig. 8.1 
The traces A and 
B are the Bodé 
plots of order 
zero for the X 
and Y proximity 
probes, which 
include the 
at-rest offsets. 

300RPM 6kRPM

A: CH1 Ord 0.00 X:6.073 kRPM Y:-80.619 minchpk
-80

minchpk

-85
minchpk

Real

X:6.073 kRPM Y:1.74076 minchpk

300RPM 6kRPM

B: F5 ((TRACK51/
3

minchpk

-2
minchpk

Real

Disp Frmat

Date:06-16-97 Time:10:01:00AM

300RPM 6kRPM

X:6.073 kRPM Y:-77.432 minchpkC: CH2 Ord 0.00
-77

minchpk

-79
minchpk

Real

X:6.073 kRPM Y:633.127 uinchpkD: F5 ((TRACK51/
800

uinchpk

-200
uinchpk

Imag

300RPM 6kRPM

Fig. 8.2 
By subtracting 
out the at-rest 
values from the 
order zero data 
and combining 
the results in a 
Nyquist Diagram 
of X versus Y, an 
axial view of the 
shaft position 
change versus 
RPM is produced. 
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values isolates the change in gap 
versus RPM.  The Y gap change is
multiplied by K4 (K4 = 0 + j1).  The 
Y axis data is thus converted to 
imaginary data (+90° rotation) and
the addition combines Y gap data
with X gap data into one data record.  

The measurement setup also tracks
orders 1, 2, 3, and 4 for two inputs,
measured with a 50 RPM increment
arming from 600 to 6000 RPM as in
Fig. 8.1 A and B.  The step-by-step
procedure at the end of this section
takes you through the process.

Some Cautions:

When working with “real” machine
data, it is highly recommended that
you audit the data by making some
independent measurements, in addi-
tion to the at-rest measurements,
using an integrating digital voltmeter.
The independent measurements of
the gap voltages and manually scaling
the values to mils will provide a
means to cross-check your results
against those measured by the DSA.
The results should be reasonably
close.  If the two results are not 
within ±0.5%, recheck both the hand-
calculated and the DSA results to
understand the disagreement.  One
thing to watch out for is the DSA’s
default data scaling applied to the
math results.  Be sure that all Y-axis
scales are in REAL and Pk mils for
order zero data.  The first time calcu-
lated data is displayed on a DSA, it
will be displayed in its default Y-axis
scale of dB and rms units.  Even if the
units on a trace are set to REAL Pk,
they may be reset to RMS scaling if
measured trace data are changed.

Fig. 8.3 
The X position 
change is viewed 
by selecting trace 
coordinate Real 
Part for the math 
function F5.

Fig. 8.4 
The Y position 
change is viewed 
by selecting trace 
coordinate 
Imaginary Part 
for the math 
function F5. 
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Example of Shaft Center Line versus
Speed or Time Measurement

Shaft center line position change 
versus RPM measurements on fast
startup transients were very difficult
to make.  The diagnostic measure-
ments of center line shifts for startup
transients were usually done with
fast-sampling integrating digital volt-
meters/data acquisition instruments
or one settled for measurements 
sampled on hourly intervals as 
in heat soaks.  

The example will illustrate how 
easy these measurements are to 
make using an Agilent DSA.  Again,
waveform math is used to extract and 
format the data to display the change
in center line position versus speed.
In this example, the data came from 
a rotor kit fitted with X and Y 
proximitors with 200 volts per inch
(200 mv/mil) sensitivity.  A two-chan-
nel 25 second, time capture of a rotor
runup transient from 300 to 8000 rpm
provides the X, Y probe data for
tracking order 0.  The DSA’s analog
inputs were DC coupled and ground-
ed for this data capture.  The 35670A’s
16-bit analog-to-digital converter 
provides more than enough dynamic
range to measure the DC gap voltage
(-4V to -18V) and the dynamic order
related vibration signals.  

The order 0 Y axis coordinate is set
to REAL and the Y units are set to Pk
(peak).  Trigger arming is set to RPM
increment, with an RPM step size of
50 RPM.  The order track register 5 is
set up to track order 0 for channels 
1 and 2.  The scaled at-rest X probe

voltage was -8.41V.  The at-rest 
position would be -8.41V/200 mv/mil = 
-42.05 mils.  This value is entered 
into constant K1.  The scaled at-rest 
Y probe gap is -7.87V/200 mv/mil = 
-39.35 mils.  This is entered into 
constant K3.  The math function 
subtracts the at-rest position in mils
from measured and scaled values in
mils.  The at-rest value in mils is not
an absolute value in that zero volts
does not equal zero gap.

Recalling the Example 
Measurement State

Recalling the example measurement
state will set up the measurement
parameters outlined above and con-
figure the display traces.  After the
order track measurement is started,
the order track 5 register results
(order 0) are extracted from the time
capture buffer and displayed in the 
A and C traces.  The at-rest X-Y gap
values were entered into K1 and K3
constants for math function F5.  The
at-rest values are subtracted from 
the zero order data for display in the
B and D traces.

Insert the disk “Agilent 35670A Rotor
Dynamics Measurements Techniques”
into the analyzer.
Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “RNUPDC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE

Verify that the prompt at the top of
the analyzer screen shows “RECALL
CAPTURE = RNUPDC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “CNTRLN.STA”. 
Press:

Rtn
RECALL STATE

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL STATE = CNTRLN.STA”.
Press:

ENTER

Rotate the marker knob to highlight
the file “CNTRLN.MTH” and then
press:

Rtn
RECALL MORE
RECALL MATH

Verify that the prompt at the top 
of the analyzer screen shows
“RECALL MATH = CNTRLN.MTH”.  
Press:

ENTER

To view the math, press:

Analys → DEFINE FUNCTION 

and verify the math and constants are
the same as the following:
F5 = ((TRACK51/K2) - K1) +
K4*((TRACK52/K2) - K3)
K1 = -4.20500e-2 +j 0.00, 
K2 = 2.00 + j 0.00, 
K3 = -3.93500e-2 + j 0.00
Press: 

Disp Format  
Start

to bring up a data display and to start
the measurement.

The X probe 0 order data are tracked
in track 51 and the Y probe data in
track 52; unscaled results will build in
traces A and C.  The result of the
math function that divides track 0 
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by 2 and subtracts the at-rest shaft
position values will build in display
traces B and D.  Marker track is on 
so the markers will track the latest
data points and display their numeri-
cal values in all four traces.  The
measurement will produce results 
as shown in Fig. 8.1.  When the meas-
urement is complete, rotate the mark-
er knob to set the marker at the start
of the track 0 data (approximately
300 RPM).  Note the values in mils Pk
in the A and C traces are very close
to two times the at-rest values in mils.

The X versus Y position data are com-
bined as Real and Imaginary values to
provide an axial view of the shaft
center line position change.  The
results are viewed by making the B
trace active, setting up a single trace
and selecting the Nyquist Diagram 
as the trace coordinates. 
Press: 

Active Trace → B  
Disp Format → SINGLE  
Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM 
Scale → TOP REFERENCE →1.5 →
BOTTOM → -0.5 → milli EXP-3

From the measurement result, the
shaft is seen to be pulled down and
wallows around at low RPM.  At
about 5400 RPM, the shaft climbs up
the oil film (Fig. 8.2).

From the measurement, it appears
that an RPM increment of 50 is a little
too coarse as the speed ramps
between 5400 RPM and 6000 RPM.
Use the marker knob to evaluate the
X-Y position change versus RPM.

Save the data in data register D1 to
compare with next result.  Press: 

Save Recall → SAVE DATA → 
SAVE TRACE → INTO D1

The RPM increment will be 
decreased in an attempt to improve
the resolution and the speed range
will be extended from 6000 RPM to
8000 RPM.  Press: 

Freq → MAX RPM → 8 → KRPM

The RPM increment is reduced to 
25 RPM as follows:
Press: 

Trigger → ARM SETUP →
RPM STEP SIZE → 25 → RPM
Start 

When the measurement is 
complete press: 

Active Trace → A 
Meas Data → MORE CHOICES →
DATA REGISTER → D1  
Active Trace → A B 
Scale → TOP REFERENCE → 3 →
BOTTOM → -0.5 → MILLI EXP-3
Active → B 
Disp Format → SINGLE FRONT/BACK
Marker → COUPLED ON OFF → ON

Rotate the marker knob slowly to
observe the data point values.  
The shaft position changes above
6000 RPM get rather interesting. 

The result of overlaying Fig. 8.2 with
the new measurement shows that
there was a very small improvement
in the measurement point spacing
(Fig. 8.5).  The lack of additional 
measurement points indicates that
the speed ramp rate was too fast
above 5400 RPM to provide enough
samples to produce additional mea-
surement at the 25 RPM spacing.  The
shaft center line position change
above 6000 RPM is very interesting
and this behavior has repeated over
several runups.

Manual Setup

The manual measurement state setup
procedure for Section 8 is found in
Appendix B.

Fig. 8.5 
The overlay of 
the 6000 RPM and 
the 8000 RPM 
Nyquist Diagrams 
of position change 
show very little 
improvement in 
RPM resolution 
above 5400 RPM 
due to too fast 
of a speed 
ramping.
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One of the well-liked features of the
Digital Vector Filter Analyzer was its
large numerical display of magnitude,
phase, and RPM.  The numerical 
display of data is often preferred 
over spectra during heat soaks and
long-term monitoring of machines.
The DVF’s large numerical display of
a selected order could be viewed
from some distance away.  

A very flexible numerical table of
order magnitude, phase, and RPM is
available in the 35670A.  The 35670A
data table can be set up for display of
Pk-Pk order magnitude, phase and
RPM for 10 or more orders from two
inputs or for three or more orders 
on up to four inputs.  The data table
shows selected values from any mea-
sured data and trace coordinates in
the analyzer.  The desired display is
provided by the Data Table function
in the Analysis menu.  A large multi-
sync display terminal can be attached
to the 35670A video output to
increase the display size for remote
viewing.  The example that follows
provides the step-by-step procedures
for data table setup in the 35670A.

Example: Numerical Display of
Order Magnitude, Phase, 
and RPM Setup

With waveform math, live magnitude,
phase, and RPM are available 
from the Computed Order Analysis
instrument mode.  The order data
records are Fourier transformed and
displayed.  The polar coordinate dis-
play is selected to provide both the 
magnitude and phase in one trace.
The data table is set up with the 
required orders to be displayed as in

Fig. 9.1.  The numerical display table
overlays the spectrum in the back-
ground.  The displayed values are
specified orders, frequencies, or
times from the background trace. 

In this example, the runup time 
capture data, state, and math files
are recalled to quickly display the
data tables and how they function.
The next part of the example is a
step-by-step walk through of the key
sequences to set up the data tables.

Fig. 9.1 
The data table 
on the Agilent 35670A 
provides a live 
numerical display 
of the data from 
the background 
trace it overlays. 
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Recalling the Files 

Insert the disk “Agilent 35670A Rotor
Dynamics Measurements Techniques”
into the analyzer.
Press:

Save / Recall → CATALOG ON / OFF → ON

Rotate the marker knob to highlight
the file name “RNUPAC.TIM”.
Press:

RECALL DATA → RECALL CAPTURE.

Verify that the prompt at the top of
the analyzer screen shows “RECALL
CAPTURE = RNUPAC.TIM”.
Press:

ENTER

Recalling the time capture file will
require about one minute.

Rotate the marker knob to highlight
the file “DSPNUM.MTH” and then
press:

Rtn
RECALL MORE
RECALL MATH

Verify that the prompt at the top of
the analyzer screen shows “RECALL
MATH = DSPNUM.MTH”.  
Press:

ENTER

Rotate the marker knob to highlight
the file “DSPNUM.STA”. 
Press:

Rtn
RECALL STATE

Verify that the prompt at the top of
the analyzer screen shows “RECALL
STATE = DSPNUM.STA”.
Press:

ENTER
Disp Format
Start

The numerical values will begin to
update in the table as the data in the
spectra are updated every 60 RPM.
Press: 

Disp Format → UPPER LOWER
Start 
Active Trace → CD

Measurement State Setup 

The manual key strokes that were
used to set up the measurement state
on the disk are:

Preset → DO PRESET 
Inst Mode → ORDER ANALYSIS →
TIME CAPTURE →
MEASURE FROM INPUT BUFR → BUFR
Input → ALL CHANNELS →
XDCR UNIT CH* SETUP →
XDCR UNITS ON OFF → ON →
XDCR SENSITIVITY → 200 →
V/EU → XDCR UNITS LABEL →
MORE CHOICES → INCH
Freq → MIN RPM → 300 → RPM →
MAX RPM → 8 → KRPM
Trigger → EXTERNAL TRIGGER →
ARM SETUP → RPM STEP ARM →
RPM STEP SIZE → 60 → RPM

Waveform Math

The waveform math functions 
F1 and F2 calculate the linear spectra
for use in the data table.  

The waveform math equations for 
linear spectra are:

F1 = FFT (Time 1)
F2 = FFT (Time 2).

If your 35670A has 4 inputs you can
also define:

F3 = FFT (Time 3)
F4 = FFT (Time 4)

The key sequence is as follows:

Analysis → MATH FUNCTION →
DEFINE FUNCTION → DEFINE F1 →
OPERATION → FFT(  → MEASURED DATA →
CHANNEL 1234 → 1 → TIME1 → ) →
ENTER
DEFINE F2 → OPERATION → FFT ( →
MEASURED DATA → CHANNEL 1234 → 2 →
TIME2 → ) → ENTER
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Display Setup

To display magnitude and phase of
channel 1, make trace A active.
Press: 

Active Trace → AB  
Disp Format → QUAD → MORE →
PHASE LAG ON OFF → ON 
Meas Data → MORE CHOICES →
MATH FUNCTION → F1 
Active Trace → CD → F2 
Active Trace → ABCD →
Trace Coord → LOG MAGNITUDE →
Y UNITS → AMPLITUDE PP PK RMS → PP
Scale → AUTOSCALE ON OFF → ON 
Active Trace → A
Trace Coord → MORE CHOICES →
POLAR DIAGRAM
Analys→ DATA TABLE → TABLE ON OFF 
→ ON 
Active Trace → C 
Trace Coord → MORE CHOICES →
POLAR DIAGRAM
Analys → DATA TABLE →
TABLE ON OFF → ON
Active Trace → B  
Marker → MARKER ON OFF → ON →
COUPLING ON OFF → ON →
MARKER TO PEAK 

The marker will be set to the peak
value in the B trace, which will be
order 1.  The magnitude and phase of
the first order can be read at the top
of the A and C traces and in the data
tables (Fig. 9.1). 

Any order can be selected for the
table by moving the marker to the
ORDER and pressing: 

Analys → DATA TABLE → SELECT X ENTRY
→ 11 → INSERT X VALUE → Marker Value

Note: The Marker Value button is in the
numerical key block.

The 11 is the table line number.  The
order is selectable over the measure-
ment range with a resolution set by
the delta order value in the 35670A.
Press: 

Start

As soon as data appear in the trace,
press the 

Pause Cont

button.  This will pause the measure-
ment.  The next few steps will set up

the data tables for all traces.  First, all
four traces will be overlaid by data
tables.
Press: 

Active → ABCD
Analys → DATA TABLE ON OFF → ON →
OFF → ON

Next, the data tables will be cleared
and then be set up to monitor the
first 10 orders.  With all traces active,
press: 

CLEAR TABLE → CONFIRM CLEAR  →
SELECT X ENTRY

Fig. 9.2 
The data tables 
are overlaying 
the background 
traces and reflect 
the specified data 
available in 
that trace.

Entry Label Order inchpp deg

1 1.366 m 145.2
2 51.391 u 32
3 92 u 335

A: F1 FFT(TIME1) X:600 mOrderM:12.013 u* P:336.22 deg

PolarLag

X:600 mOrder Y:12.0132 uinchpp

Entry Label Order inchpp

1 1.366 m
2 51.391 u
3 92 u

B: F1 FFT(TIME1)

LogMag

Disp Frmat

Entry Label Order inchpp deg

1 833.466 u 239.2
2 236.355 u 225.6
3 69.764 u 314.8

X:600 mOrderM:8.6013 u* P:22.546 degC: F2 FFT(TIME2)

PolarLag

Entry Label Order inchpp

1 833.466 u
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The analyzer will echo: 

“SELECT X ENTRY = 1” →
ENTER → INSERT X VALUE 

which will echo “INSERT X VALUE =
0”.  At this point press: 

1 → ORDERS 

This will enter order #1 as the data in
table position one. The X entry will
automatically index to 2. 
Press: 

INSERT X VALUE → 2 → ORDERS → 3 →
ORDERS → 4 → ORDERS → 5 →
ORDERS → 6 → ORDERS → 7 →
ORDERS → 8 → ORDERS → 9 →
ORDERS → 10 → ORDERS  

The automatic indexing will have
filled the first 10 table positions with
your selected data.
Press: 

MARKER ON OFF → ON →
SELECT X ENTRY → 1

Rotate the knob to scroll through 
the tables and return so that entry 1
is at the top of the data table.  Note
how the data table has automatically
picked the x and y coordinate values
from the background traces associat-
ed with the orders specified (Fig. 9.2).

We will now deactivate the data table
for Traces B and D.

Active Trace → B → TABLE ON OFF →
OFF → Active Trace → D
TABLE ON OFF → OFF

The data tables overlay the traces in
the background and can reflect all or
part of the data in the trace.  The A
and C traces are polar diagrams,
which are three-dimensional plots
with magnitude and phase in the
plane view and the order axis coming
out of the DSA screen.  The data table
reflects the magnitude and phase for
the selected orders in the trace.  The

data table for B and D traces with 
a magnitude spectra can display 
magnitude only. (Fig 9.1)

In the data table menu press: 

MARKER ON OFF → OFF → ON 

and observe the effects on the 
active trace D.  Press: 

Start

Note that the orders listed in tables
and traces are updated automatically
every 60 RPM as the analyzer reduces
the data in the capture file.  The final
result at 8000 RPM will be very close
to the results in Fig. 9.3.

Labeling Table Entries

Table entries are easily labeled using
the alpha subscripts of the front
panel buttons or by using an external
PC keyboard. 
Press: 

Active Trace → ABCD 
SELECT X ENTRY → 1 → ENTER →
ENTRY LABEL 

The echoed message will be 
“ENTRY LABEL = ” and the DSA
will be in the alpha mode ready for
the alpha characters to be entered.
Enter: 

X → INSERT SPACE → P  R  O  B  E →
INSERT SPACE → M  A  I  N →
INSERT SPACE → B  R  G → ENTER 

Fig. 9.3 
The data tables 
overlaying the 
polar plot in 
traces A and C 
display magnitude 
in PP mils and 
phase lag.  When 
the data table 
marker is on 
as in the linear 
spectra of B and 
D traces, the 
table is shown.

Entry Label Order inchpp deg

1 1.366 m 145.2
2 51.391 u 32
3 92 u 335

A: F1 FFT(TIME1) X:600 mOrderM:12.013 u* P:336.22 deg
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The label has been entered in all the
data tables for entry #1.  Next, the
label for the C and D traces are 
modified.   Press: 

Active Trace → CD → ENTRY LABEL 

The prompt line “ENTRY LABEL = 
X PROBE MAIN BRG” will appear.
Turn the marker knob to highlight the
“X “and Type the letter “Y” and press: 

DELETE CHARACTER 

to delete the “X”.  Press: 

ENTER

and the label now reads “Y PROBE
“MAIN BRG”. The result will look 
like Fig. 9.4.
Press: 

Active Trace → AB 
Disp Format → UPPER LOWER
Start

The Data Table Marker function also
prints the last table entry values on
the associated spectral plots as
shown in Fig. 9.5

The 35670A video out can be connect-
ed to a large screen multi-sync moni-
tor, which makes the data tables
much more visible.  The monitor can
be located some distance from the
DSA.  The data tables allow you to
observe the stability of the order’s
magnitude and phase numbers during
heat soaks without the need to be
right in front of the analyzer.  Multi-
sync monitor technology and models
are changing rapidly.  It may be 
necessary to use a video amplifier or
converter for this to work correctly.

Fig. 9.4 
The data table 
entry lines can 
be labeled as 
required line 
by line.

Entry Label Order inchpp deg

X PROBE MAIN BRG 1 1.305 m 145.1
MAIN BEARING 2 84.079 u 25.2

3 15.81 u 290.2

A: F1 FFT(TIME1) X:200 mOrderM:3.9394 u* P:336.07 deg

PolarLag

X:200 mOrder Y:3.93944 uinchpp

Y PROBE MAIN BRG

1Order MAIN BEARING

2Order

3Order
4Order 5Order

6Order 7Order
8Order

9Order

10Order

0Order 10Order

B: F1 FFT(TIME1)

10
minchpp

1
uinchpp

LogMag

Analysis

Entry Label Order inchpp deg

Y PROBE MAIN BRG 1 783.533 u 237.2
MAIN BEARING 2 230.073 u 224.3

3 86.407 u 304.7

X:200 mOrderM:905.56 n* P:292.01 degC: F2 FFT(TIME2)

PolarLag

X:200 mOrder Y:905.564 ninchpp

X PROBE MAIN BRG

1Order

MAIN BEARING

2Order

3Order

4Order

5Order

6Order

7Order

8Order 9Order
10Order

D: F2 FFT(TIME2)

10
minchpp

1
uinchpp

LogMag

0Order 10Order

Fig. 9.5 
The label as well 
as the order, 
frequency, or 
time values from 
the data table are 
printed on the 
plots next to 
their associated 
marker as on 
the trace above.

B: F1 FFT(TIME1) X:200 mOrder Y:3.93944 uinchpp

0Order 10Order

10

minchpp

1

uinchpp

LogMag

4

decades

Disp Frmat

X PROBE MAIN BRG
1Order

MAIN BEARING
2Order

3Order

4Order

5Order

6Order

7Order

8Order 9Order

10Order

Fig. 9.6
An external
monitor allows
the Agilent 35670A
display to be
enlarged and
placed remote
from the DSA.
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Proximity probes are in a general
class of non-contacting displacement
transducers.  Several position sensing
techniques are used by non-contact
displacement transducers, including
capacitance, optical, laser, and induc-
tive (eddy current) transducers.  The
most widely used non-contacting
probes on rotating machinery are 
the eddy-current type, commonly
known as proximity probes.  Proximi-
ty probes are used because they 
are durable, and they can directly
measure shaft to bearing clearance.  
(Fig. 10.1).

The eddy-current proximity probes
consist of two parts, the probe and
the oscillator/demodulator (Fig. 10.2).
The high-frequency oscillator is used
to induce an eddy current on the
shaft’s surface without actually touch-
ing it.  The eddy-current probes can
sense the gap between the probe tip
and the conductive surface of the
rotating shaft.  As the shaft moves 
relative to the sensor, more or less
energy goes into the eddy current.
These eddy-current energy changes
modulate the amplitude of the oscilla-
tor voltage.  This signal is demodulat-
ed, providing an output voltage
proportional to the change in gap.  
In a typical proximity probe the volt-
age output is a modulated signal with
a large negative DC voltage bias, or 
“set” point. 

View from drive end of the shaft

Y Proximity
Probe

X Proximity
Probe

Oscillator/
DemodulatorEddy

Current
Probe

Fig. 10.1 
A typical 
proximity probes 
configuration in 
fluid film bearing.

Fig. 10.2 
An eddy current 
proximity probe 
consists of 
two parts, the 
probe and the 
oscillator/
demodulator.

Section 10
Proximity Probe Interfacing 
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As the rotating surface moves away
from the probe tip, less eddy current
energy is lost and the voltage output
of the demodulator becomes more
negative.  As the gap gets smaller,
more eddy current is lost in the shaft
surface and the output becomes less
negative.  The indicated gap change
causes the voltage to change about
the probe’s set point.

For example, a proximity probe 
with a 200 millivolt/mil sensitivity 
will show a periodic one volt peak-
to-peak signal when measuring a 
5 mil peak-to-peak displacement.
(Fig 10.3)  The signal period will
match the displacement.  So, if the 
5 mils peak-to-peak occurs once per
revolution, the signal period will
match this speed.  Proximity probes
are ideally adjusted for an operating
set point in the middle of the probe’s
linear operating range.  Typically, a 
-24V unit will have a linear operating
range from -2V to -22V with a recom-
mended set value of -12V.  Similarly 
a -18V unit operates linearly from 
-2V to -16V with a recommended set
value of -7V.

Proximity Probe Interfacing

The interfacing of proximity probe
outputs to the 35670A is a direct 
connection.  The 35670A provides a
maximum input range of up to ±31V
peak.  The DC operating point of the
proximity probe output is well within
this range.  The 35670A has more
than enough dynamic range to meas-
ure a small dynamic signal (<10 mv)
plus the probes negative DC 
operating point offsets. 

Set the input coupling to be DC by
pressing:

Input → FRONT END CH* SETUP →
INPUT LOW FLOAT GND → GND →
COUPLING AC DC → DC 

If greater signal dynamic range is
required, the AC coupling should be
selected.  Measurements below 
180 RPM will have slightly degraded
channel-to-channel phase match and
amplitude attenuation when AC cou-
pling is used.  For a proximity probe
with a sensitivity of 200 millivolts/mil,
enter 200 volts/inch for EU (Engineer-
ing Units).  The engineering units 
of 200 millivolt/mil of a proximity
probes is equal to 200 volts per inch.

By using the fundamental units of
inches, you avoid the problem of
strange units such as milli mils 
instead of µ inches appearing on 
your plots.  Set up Engineering Units
(EU) by pressing:

Input → TRANSDUCER SETUP →
EU ON OFF → ON →
TRANSDUCER SENSITIVITY → 200 →
VOLTS PER EU → EU LABEL →
MORE CHOICES → INCH 

The DSA’s signal return (low) is 
connected to the common on the 
oscillator/demodulator.  The oscilla-
tor/demodulator output is connected
to the signal input (high).

Fig. 10.3  
Calibration 
curve of an 
ideal, linear, 
proximity probe.
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Keyphasors are often found on 
critical machine assets along with
proximity probes.  The keyphasor
provides a once-per-revolution 
φ reference signal for angular mea-
surements on a rotating shaft.  If you
have access to this signal, it will save
you the trouble of attaching a once-
per-revolution phase reference to the
shaft.  The purpose of a keyphasor is
to relate the rotating reference frame
of the shaft to the stationary refer-
ence frame of the vibration or dis-
placement sensors.  A key-phasor
sensor has similar output voltage
characteristics as a proximity probe
shown in Fig. 11.1.  

The ideal keyphasor signal would
have a very fast and large change in
voltage as a high or low spot edge
passes under the probe.  The opti-
mum setup for an eddy current phase
sensor is to adjust it for a maximum
voltage swing.  In the case where a
slot (keyway) is the reference transi-
tion, the probe “sees” a small gap for
almost the complete revolution.  The
keyphaser output will ideally be in
the -2 to -5 volt range for this small
gap portion of the revolution of the
shaft.  When the key slot passes
under the keyphaser probe, the 
output will peak to the -16 to -22 volt
range (Fig. 11.2). 

In the case where the key is the 
high spot the probe “sees” a large gap
for almost the complete revolution.
As a result the output voltage will be
in the -16 to -22 volt range for most 
of the shaft’s rotation.  As the key
(high spot) passes under the probe,
the keyphasor output will swing to 
the -5 to -2 volt range (Fig. 11.2).  

Typically, the manufacturers recom-
mend having a minimum of 60 mils
between the high/low spot transition,
which will produce a 12-volt swing.
The key or slot should be at least two
probe tip diameters in width.  In the
field, you are likely to encounter a
very large variation from these ideal
phasor voltage signals.  In one case, a

Fig. 11.1 
A typical keyphasor 
setup with a slot 
(key slot) passing 
under the probe.  The 
voltage swing goes 
from the -2V to -5V 
range for almost the 
complete revolution 
to the -16V to -22V as 
the slot passes under 
the probe. 

CW

Key
Phasor

0

-20V

Rev
-4

0°

Fig. 11.2 
A typical keyphasor 
setup with a key 
(high spot) passing 
under the probe.  The 
voltage output is -16V 
to -22V range for almost 
the complete revolution, 
but goes to -2V to -5V 
range as the key passes 
under the probe.

CW

Key
Phasor

0

-20V

Rev-2

0°

Section 11
Keyphasor Interfacing
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flat of only a few mils was ground 
on a shaft surface.  The keyphasor
signal was useless because the shaft
dynamics produced a larger signal
than the flat.

Two inputs on the DSA can interface
to a once-per-revolution phase refer-
ence.  They are the tach input and 
the external trigger input.  The tach
input can be set up to handle from 
1 to 2,048 pulses per revolution.  The
external trigger input requires a once-
per-revolution pulse to identify the
shaft time 0 or angle 0 reference.  The
phase reference can be input to the
external triggering input or to any
one of the analog input channels.
Even when the tach input is only one
pulse per revolution, the once-per-
revolution phasor signal needs to be
connected to a trigger input if phase
is to be extracted from the measured
data.  The separation of the tach and
trigger inputs allows the DSA to take
full advantage of the better angular
accuracy available from a multiple-
pulse-per-revolution tach.

The best practice is to first view the
keyphaser signal and determine the
optimum trigger level and slope to
ensure a reliable firing on the leading
edge of the once-per-revolution phase
reference.  The example describes 
the interfacing issues for the 
35670A in more detail.

Keyphasor Tachometer Interfacing

First, view the phasor signal and
determine the optimum trigger level
and slope.  This is to ensure a reliable
trigger on the leading edge (left hand,
first transition) of the once-per-
revolution phase reference.  The

keyphasor signal should be connect-
ed to the tach input, external trigger
and to the channel 1 input.  Using
BNC tees will make this easier.  The
external trigger and tach input are 
on the rear panel of the 35670A.  
The keyphasor signal should be a
once-per-revolution pulse train rang-
ing from -2 to -22 volts.  The phasor
tach signal is most easily viewed
using the FFT mode to make time 
domain measurements in the DSA.
Press: 

Preset → DO PRESET

This sets the Measurement Mode to
the FFT ANALYSIS mode.  
Press: 

Meas Data → TIME CHANNEL 1  
Start 

and adjust the measurement time to
view 2 to 4 tach pulses in a time
record.  To adjust time press:

Freq → RECORD LENGTH 

and use ⇑ to increase the measure-
ment time to display the 2 to 4 pulses.
Next press: 

Pause

and use the marker to determine the
voltage swing of the phasor signal,
slope of the leading edge, and its 
midpoint.

The tach input has two input ranges,
±20 and ±4 volts.  Select the range
that is appropriate for the phasor
voltage swing, i.e., a swing from -5V
to -15V would indicate a -10V trigger
level (Fig. 11.2).  The output of opti-
cal tachs is typically 0 to +5V and the
±4V trigger range would be selected
and a level of +2.5V would be set as
the tach trigger level.

Press: 

Trigger → TACHOMETER setup →
TRG RANGE +/– 20 4  

is toggled to a voltage range 
appropriate for the voltage swing of
the phasor signal.  Next press:

LEVEL 

and enter a level that is at the 
midpoint of the voltage swing.  
Next press:

SLOPE

to toggle to the slope of the 
leading edge of the phasor signal.
Since the leading edge is heading
downhill for the keyphasor in 

Fig. 11.3
A typical optical tach 
provides a TTL output 
level (0 to 5V).  The 
EXT TRIGGER level 
selected would be 
compatible with TTL.

CW

Reflective
tape

Optical Tachometer
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Fig. 11.1, the slope NEG would be 
selected.  The slope selection for 
the signal in Fig. 11.2 would be POS. 

The trigger input on the 35670A pro-
vides both a ±10V and a ±2V trigger
range.  These can be used provided
the phasor’s output swings through 
-8V or -2V ranges.  Moreover the 
phasor output must reach below a
level of -10 V or triggering problems
are likely due to shaft center line
shifts with speed.  The interfacing of
a keyphasor signal outside the 
-8V range (-8V to -22V) can be han-
dled by using a voltage attenuator.  A
2 to 1 voltage divider can be easily set
up by attaching a 40 kOhm 1/8 watt
resistor to the keyphasor output ter-
minal and connecting it to a BNC
adapter.  (As shown in Fig 11.4).  This 
series resistor should be inserted in
the demodulator output line.  Using a
BNC adapter with alligator clips
makes this very easy.  However great
care should be used to avoid shorting
out the demodulator.  The use of insu-
lating sleaving on the resistor lead is
highly recommended.  Typically the
red lead in the adapter is the center,
or signal line.  Connect the signal line
to the other end of the resistor.  The
attenuator will bring the -10V to -20
levels down to the -5V to -10 range,
well within the ±10V trigger range.

Another approach to the keyphasor
interfacing problem is to use a block-
ing capacitor (Fig. 11.5).  A polarized
capacitor of 20 to 50 µF with 50V or
higher voltage rating will work well.
The capacitor will block the DC 
portion of the signal and allow the 
dynamic part to pass through.

It is recommended that the attenuat-
ed or AC coupled keyphasor signal be
measured and viewed.  To view the
signal, connect it to the TACH INPUT,
TRIGGER INPUT, and to CHANNEL 1
input.  As described previously, use
the FFT mode to display the time
domain tachometer signal.  Change
the Record Length using the frequen-
cy menu to view 2 or 3 tach pulses.  
With the marker you can easily deter-
mine the tachometer signal voltage
swing and midpoint.  You can then set
the tachometer parameters correctly.
Press: 

Trigger → TACHOMETER setup →
EXT LEVEL USER TTL →
USER TRG RANGE ±10 2 → 10

Next press:

LEVEL 

and enter a level that is at the mid-
point of the voltage swing if possible. 

Next press:

SLOPE NEG POS

to toggle to the slope of the leading
edge of the phasor signal.  Turn on
the tachometer display and set the
trigger levels.  

TACH DISP ON OFF → ON → Rtn →
EXTERNAL TRIGGER → TRIGGER SETUP →
EXT LEVEL USER TTL → USER →
USER EXT LEVEL 

is set to an appropriate level.  Set: 

SLOPE POS NEG →

To an appropriate value. 

The tach signal and the tach display
should now appear stable.  If the tach
display and waveform are not stable
or a “WAITING FOR TRIGGER” mes-
sage appears, recheck the level and
hookup.  Refer back to the paragraph
above on attenuating the phasor 
signal for the trigger input.

Fig. 11.4 
A simple 2 to 1 
attenuator can 
be made using a 
BNC to alligator 
clip adapter.  
The keyphasor 
output level will 
be brought down 
to within the 
±10V range of 
the EXT TRIGGER 
INPUT of the 
Agilent 35670A.

Fig. 11.5 
Connecting a 
DC blocking 
capacitor to the 
keyphasor output 
terminal with a 
BNC to alligator 
clip adapter.   
The resulting 
keyphasor will 
be centered 
on VDC.

40k Ohm

-18V to -24V

Output

COM

Oscillator/Demodulator

-18V to -24V

Output

COM

Oscillator/Demodulator

20 to 50 µfd
50V

+ -

Note correct capacitor polarity.
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Manual Measurement State Setup

The following is the detailed step-by-
step setup procedure for manually
doing slow roll removal.  This proce-
dure is provided as a reference.

The Inst Mode is set to ORDER 
ANALYSIS.  The order resolution is set
to 1 order so 1 revolution per record
is displayed (Fig. 4.3):

Freq → DELTA ORDER → 1

The proximity probes nominal 
engineering units values were 
entered by pressing:

Input → ALL CHANNELS →
XDCR UNIT CH* SETUP →
XDCR SENSITIVITY 200 → V/EU →
XDCR UNIT LABEL → MORE CHOICES →
INCH → Rtn → Rtn (pressed twice)

Next press: 

XDCR UNIT ON OFF → ON  

The 200 mv/mil calibration factor for
the probe was entered as 200 V/inch.
Using the basic units of inches
instead of 200mv/mil will prevent
strange units such as milli mils 
instead of µ inches from appearing 
on the X or Y axis.

Press: 

Rtn
FRONT END SETUP → AC/DC → AC  

AC coupling on the analog inputs was
selected to block the -8V DC of the
proximity probe that the dynamic gap
signals ride on.  An optical tachome-
ter was used to produce the 0 to 5V
once-per-revolution tach/trigger signal
for the example data.

It is recommended that the tach sig-
nal be measured and viewed.  The
phasor signal can be connected to the
tach and trigger inputs.  The tach and
trigger levels and the slopes should
be set to fire in the middle of the
leading edge of the tach signal.  The
tach level should be set so that no
tach pulses are missed and there are
no false triggers.  The tach display is
turned on and the stability of the
RPM observed.  Jumps in RPM are an
indication of an inappropriate tach
level.  Magnetic tachs are especially
prone to producing both unstable
RPM displays and phase errors
because their peak level, slope and
wave shape are likely to change 
radically with RPM.

Setting up the analyzer for a 
2 trace display for slow roll 
correction is done by pressing:

Freq → MIN RPM → 300 → RPM 
Trigger → EXTERNAL TRIGGER →
TRIGGER SETUP → EXT RANGE +/– 10 2 →
____ → USER EXT LEVEL → ?.? → V →
SLOPE POS NEG → NEG →
Rtn → ARM SETUP → AUTOMATIC ARM →
RPM STEP SIZE → 40 → RPM
Avg → AVERAGE ON OFF → ON →
NUMBER AVERAGES → 1 → ENTER
Active Trace → A 
Meas Data → CHAN 1 2 3 4 → 1 →
TIME CHAN 1
Active Trace → B → CHAN 1 2 3 4 → 2 →
TIME CHAN 2

The math function is as follows:
F1 = (TIME1 - D1) 
F2 = (TIME2 - D2)

The key path to enter the math is as
follows:
Press: 

Analysis → DEFINE FUNCTION →
DEFINE F1 → ( →
MEAS DATA CHANNEL 1 2 3 4 → 1 →
TIME1 → – → Data reg →
DATA REG D1 → ) → ENTER.

Press: 

DEFINE F2 → ( → MEAS. DATA →
CHANNEL 1 2 3 4 toggled to 2 and press
TIME2 → – → DATA REG →
DATA REG D2 → ) → ENTER

The slow roll records of the X and Y
proximity probes are saved in data
registers D1 and D2.  See the previous
“Modifying the Measurement State” to
continue the manual commands to 
complete the example. 

Each new order record (TIME1 and
TIME2) has the slow roll subtracted
from it to provide a live display at
two or more updates per second.

Appendix A
Slow Roll Removal
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Manual Measurement State Setup

The manual measurement state setup
procedure can proceed from two
instrument starting points.  The first
is from the power up condition where
the time capture, math, and state
have all been reset to their defaults.
The other start point is from the pre-
set state.  The preset state puts the
DSA into the FFT ANALYSIS mode
but retains the time capture, math,
and the front end setup parameters.
It is best to use the manual setup as a
guide to learn how this measurement
state is set up and to start from the
preset point.

Starting from power up, 
load “CNTRLN.STATE” and
“RNUPDC.TIM” records.  Set up 
an Order Track Measurement by
pressing:

Preset → DO PRESET 
Meas Mode → ORDER ANALYS →
TIME CAPTURE →
MEAS FROM INP BUFR → BUFR 

The track register 5 is set up to 
track order 0 for channels 1 and 2 by
pressing:

Freq → TRACK ON OFF → ON →
TRACK SETUP → TRACK 5 ORDER → 0 →
ORDERS → Rtn → MIN RPM → 300 →
RPM
Active Trace → ABCD  
MKR TRACK ON OFF → ON
Trigger → EXTERNAL TRIGGER →
ARM SETUP → RPM STEP ARM →
RPM STEP SIZE → 50 → RPM

Press: 

Analysis → DEFINE CONSTANT →
DEFINE K1 

and enter the scaled at-rest X probe
voltage (-8.41V/200 mv/mil = 
-42.05 EXP-3) and press ENTER.
Verify the correct value is in K1.
Press: 

DEFINE K3 

and enter the scaled at-rest Y probe
voltage (-7.87V / 200 mv/mil = 
-39.35 EXP-3) and press: 

ENTER

Entering the Math Function F5

The math function to scale and com-
bine X and Y gap data is: 

F5 = ((TRACK51/K2)
- K1) + 
K4*((TRACK52/K2) - K3) 

Track register 5 is set to track order 0
for channels 1 and 2.  The results are
in Measured Data TRACK 51 AND 52.
The divide by K2 = 2 scales the order
track 0 values to their correct values
in mils. 
Press: 

Analysis → DEFINE FUNCTION →
DEFINE F5→ ( → ( 
MEAS DATA → ORDER TRK CHAN 1 →
TRACK5 → / → CONSTANT K1 - K5 →
K2 → ) 
– → CONSTANT K1 - K5 →
CONSTANT K1→ ) 
+ → CONSTANT K1 - K5 → K4 → * → ( → ( 
MEAS DATA → CHANNEL 1 2 3 4 → 2 →
ORDER TRK CHAN 2 → TRACK5 → /  →
CONSTANT K2 → ) → – → CONSTANT K3
→ ) → ENTER

The waveform math extracts the
shaft center line X and Y position,
order 0, and scales them.  The at-rest
values are subtracted to compute the
change in position and combines the
X-Y gap change data into a single
record. 

Appendix B
Shaft Center Line Position 
Change Versus Speed or Time 



The Display Setup 

The unscaled shaft center line 
position versus RPM is displayed by
pressing:

Disp Format → QUAD  
Active Trace → A 
Meas Data → MORE CHOICES →
ORDER TRACK CHANNEL 1 →
TRACK 5 ORDER 0.00  
Active Trace → C  
Meas Data → MORE CHOICES →
CHANNEL 1 2 3 4 → 2 →
ORDER TRACK CHANNEL 2 →
TRACK 5 ORDER 0.00 

The B and D traces are set to display
the change in X and Y position
extracted with math function F5.

Active Trace → B  
Meas Data → MORE CHOICES →
MATH FUNCTION → F5  
Active Trace → D → F5 

The trace coordinates for the four
traces are set up by pressing:

Active Trace → A B C D 
Trace Coord → Y UNITS →
AMPLITUDE PK PP RMS → PK
Rtn → MORE CHOICES → REAL PART →
Active Trace → D → IMAGINARY PART

Assuming you have correctly recalled
the file RNUPDC.Tim, Press: 

Start

Scaling the traces is done by pressing:

Scale → AUTOSCALE ON OFF → ON 

and at the completion of the 
measurement press: 

AUTOSCALE ON OFF → OFF

The result should look much like 
Fig. 8.1.

To view the X versus Y shaft center
line position change versus RPM,
change the trace coordinates to
NYQUIST DIAGRAM.
Press: 

Disp Format → SINGLE  
Active Trace → B 
Trace Coord → MORE CHOICES →
NYQUIST DIAGRAM
Scale → TOP REFERENCE → 1.6 →
BOTTOM → -0.4 → MILLI EXP-3

The Nyquist Diagram provides an 
end view of the shaft position change
versus RPM in the sleeve bearing of
the rotor kit (Fig. 8.2).

To display the X transducer 
position change, press:

Trace Coord → MORE CHOICES → REAL 
Scale → TOP REFERENCE → 1.6 →
BOTTOM → -0.4 → MILLI EXP-3

The display on the 35670A will look
like Fig. 8.3.  The shaft is pulled to
the left about 0.25 mils at low RPM
and then moves to the right about 
3 mils at 6400 RPM viewed from the
motor end.  The motor was turning 
counterclockwise.

To view the Y gap change versus
RPM, press:

Trace Coord → MORE CHOICES →
IMAGINARY

The shaft stays at the at-rest position
at low RPM and then rises up on the
oil film as RPM increases (Fig. 8.4).

Continue from top of the middle 
column on page 35.
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